MEIZU MX 4 PRO - huge problems with WIFI

Hi,
I’ve bought a Meizu MX4 Pro. Unfortunately not the international version. During I tried to add the German language, the mobile phone has updated to Flyme 6.1.0.0A. After that my son has tried it again and made a reboot.
Since that the mobile phone no longer finds our WIFI (was previously logged in). I rebooted it again and it found the WIFI again, but after entering the access code it was lost again. Now it does not find the WIFI again.
What can I do? Could anyone help me, please?

Warm Regards,
Martin

Meizu m3s

Which method did you use to add new language?
You can try this method to convert the phone to international. (suggest you look into method 2 or 3)
https://forum.meizufans.eu/topic/2599/guide-how-to-install-i-international-firmware-on-your-chinese-mainland-meizu
If WIFI still does not work please connect your phone to a pc and copy the files instead.

Thank you very much.

Have you got an idea of the problem with the WIFI?
The cellphone connects with the WIFI for a short term, after a some seconds the cellphone looses the connection again. And than the same from the beginning.

Martin

Meizu m3s

Either there are drivers corrupted when installing the update or your wifi card is overheating.
I would suggest you to reinstall the firmware to test if it is not hardware problem.

excuse me, how do I have to do it? How is the right way to reinstall the firmware?

@Firekid Reinstalling the firmware is possible via the recovery

  • Shut off the phone
  • Press Power + Vol Up
  • When Meizu Logo pop up release it and you will be in the recovery with 2 options
  • Update / Clear Data

Choose first update should be enough to solve the problem I think if not you can also try to clear data wich will lead to wipe all your data so be careful and make backup !

Normally you should already have a firmware on the root of your phone but if needed all the firmware for your devices are here

Download it and put it on the root of the phones and do the same as step 1 with recovery etc

last edited by Vympel

hi
i have mx4 pro
i have same problem with wifi
changed rom but wifi problem not solve
please help me

We can’t do much more than this if both way (upgrade and wipe) didn’t produce any results.
Try to downgrade to an older build maybe it may related to a bug or so…

Try Too reflash with Clear Data Option

Hello,

Once again I turned on the phone. And suddenly it finds the WLANs again. There is also a connection with the WLAN, but this is unfortunately not held permanently. Then it disappears, but after a while it builds up again.
What is going on now??

Meizu m3s

Have you tried reinstalling the firmware?
If you have already please try the Meizu service centre.

I have exactly the same problem
I tried a lot, but I did not succeed

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.