New update of flyme caused problem with Google Play

I have Meizu M2 and 3 days ago, I had a notification for updating Flyme. When the update completed successfully, many Google Apps like Google Play , Google Maps, Google Services were missing from the phone and I can’t reinstall them from “Hot Apps”. I have even tried to install them with apks. Is there any way to solve this?

last edited by hullifer

It’s the same story as always.
Install the GMS (Google installer) and the rest will be installed normally.

I did and it get’s stuck at 82% of the procedure.

Meizu m3s

Try uninstalling all google related apps and then download GMS installer from here https://downloads.meizufans.eu/?dir=apps/google_installer. If the latest version doesn’t work try another version. If neither work try reinstalling or downgrading flyme. To download firmwares check here https://downloads.meizufans.eu/?dir=m2/firmware.

Thanks for the info. Fixed my problems too. Spent half a day searching for other solutions till I cam across this.
It’s stuff like this that is making me part ways with Meizu…After the update, none of my taxi apps worked and gmail stopped syncing . Gonna be giving my phone to my daughter and moving away from Meizu altogether. Meizu might be cheap and cheerful , but it’s not reliable for grown up users.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.