Flyme OS 6.7.5.23 beta (MX4)

Hi,

I need some help. Actually I have installed Flyme 6.7.4.25 and when I try update to newer version recives “Firmware corrupt”.

When I try downgrade as always to 4.5.6I(4.5.6A)->4.0.4 or Flyme 5 recives “Couldn’t get update file info”.

Is any other way to update?

yes, but finally solved this problem.

I move flyme 4.5.6I update to root directory, run phone in recovery mode and then update successfully installed :)

after that I can normally downgrade to 4.0.4I and install last stable flyme 6.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.