Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

Flyme OS 6.7.3.28 beta (Pro 6)

@twingor i think A because of 6.7.3.3 beta for G. This version number like as downgrade ;) 

is there anyway to install this to pro 6s? no one talks about pro 6s. i think i shouldnt buy 6s. what do you think?

Meizu Pro 6

@algebram if i were you i would wait for the pro 7. As for your question it cannot be installed on the pro 6s as it is for the pro 6.

Looks like your connection to Flyme OS 6.7.3.28 beta (Pro 6) was lost, please wait while we try to reconnect.