Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

Flyme OS 6.7.3.14 beta (m2 note)

cannot upgrade.i get the message ‘Ugrade Corrupted’.
i tried many times

Is this A or G firmware? It's ok, it's A firmware. Downloaded but same for me, won't install, says file is corrupt.

last edited by Hummer

tried on my friend’s phone too.corrupted again

Looks like your connection to Flyme OS 6.7.3.14 beta (m2 note) was lost, please wait while we try to reconnect.