Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

Upgrade Flyme 6 failed

Hi, my phone is flyme 5.2.4.0G. I can see there are only flyme 6.0.2.0Y for download. I try to upgrade but keep getting firmware corrupt. I have tried all the method online. However, still the same result. Is firmware G only be able to upgrade using firmware G only? Please kindly help. 

Meizu m3s

Are you sure you have a Meizu U20? I didn’t even know it exist. You maybe able to update your firmware through custom methods: https://forum.meizufans.eu/topic/2599/guide-how-to-install-i-international-firmware-on-your-chinese-mainland-meizu
Try method 2 , using DD and root. It maybe time consuming and i would stay on 5.2.4.0G than go use a “Y” firmware.

I don’t think it works for me. As u20 does not support root, it is under Yunos and no root option…
I think I may need to wait until the G firmware support OTA…

Looks like your connection to Upgrade Flyme 6 failed was lost, please wait while we try to reconnect.