app doesnt work on mobile data, but works in wifi,


i had flyme os wich one was when i bought a phone, i think it was flyme os ~4.5. I have an app wich one is using phone imei. In 4.5 version it worked fine. After i upgraded my phone to Flyme, what app is working when using wifi, but when using mobile data, it doesnt works. I noticed that in version my phone has 2 imei codes, tried to assign both imei codes from app server. The app that i am talking about, is an app that is showing some information to person from database and location settings must be turned on. App is working in wifi, but it doesnt works in mobile data (4g). With app is everything ok, its problem with phone. Tried to assign only second imei, but still same. Maybe someone has any ideas about it? Also tried flyme 6... beta for m2 note, still same. 

Sorry for bad english, and thanks for help.

Meizu m3s

Try to recover the imei using su. It maybe a corrupted nvram. Try looking searching solutions online.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.