Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

Salve files -locked Meizu M2

Hi everyone!

Some weeks ago I locked my Meizu M2: now just a black screens shows up requesting for Flyme password. I know it, but because of a firmware bug the device does not unlock. Customer service said to me they can unlock my phone, but all my data will be lost.

So I am trying to find a way to save my data before the reset: I thougt to install a TWRP and then to backup my files with ADB, but recently I discovered that I have to unlock the bootloader first. And I cannot do it with on a locked phone… So I just wanna ask you: am I missing something? Do you know other ways to save my files?

(PS: no, no I don’t have a cloud backup of my photos…)

Meizu MX4

@Mr.me Have you tried reflashing the firmware through the recovery without wiping data?

Hmm… In order to do this, should I select the stock rom in SP FlashTool, instead of the TWRP?

Thank you!

Meizu m3s

I don’t think sp flash tools work for the m2 mini. I have only heard it to work with the m2 note. Are you sure your bootloader is locked, normally you cannot install twrp on locked bootloader. To test just try installing the stock recovery through fastboot.

Edit wait, is twrp working?

last edited by Scorpiony Knifet
Meizu MX4

@Mr.me Not through flash tool, but with the stock flyme recovery. I think you need to hold power and volume- , and when you enter the recovery connect your phone to a pc. You will se a recovery drive, download a firmware, preferably the same that you already have and copy it to the drive. Then go to update in the recovery but dont wipe data so your files stay.

Hi everyone! thank you for helping me and sorry for the delay!

@Jovica-Lalic : the problem is that when the device is locked you cannot enter the recovery mode (I mean the defalut one which displays a black screen with a white baloon and let you choose between system upgrade and clear data)…

So I tried to install the stock recovery, as suggested by @Scorpiony-Knifet :
You are right, I cannot install a TWRP since the bootloader is locked. I searched through the web/forums for a custom recovery matching with my firmware: (4.5.4.I) i found two. I tried to install with fastboot but in one case I got this error.

sending ‘recovery’ (19794 KB)… OKAY
writing ‘recovery’… FAILED (remote: download for partition ‘recovery’ is not allowed)

and in the other case I was stuck on “sending recovery…” for a night, the following day I found:
sending ‘recovery’ (16384 KB)… ERROR: usb_read failed with status e00002ed

As far as you know, do I need to unlock the bootloader (i.e. wiping my data), in order to flash with a stock recovery?
Thank you!

Looks like your connection to Salve files -locked Meizu M2 was lost, please wait while we try to reconnect.