Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

Bootloop while downgrading

0

Hello, I’m new to the forums so I apologize in advance if there has been a topic with this exact problem, but I browsed and couldn’t find a solution (or tried and failed).

Namely, I had problems with the latest m2 firmware (when people would call me, I was unavailable, and a minute later I would receive a sms that I had a missed call), and I decided to downgrade to 4.5.4.
This was not my first downgrade, so I kind of knew what I was doing.

I copied the update.zip to the root folder, pressed vol+ and power, entered recovery mode, ticked update and clear data, and clicked start. After updating the phone would restart and I would return to the recovery mode again. This time, I just ticked restart, and I got stuck in bootloop (flyme icon would show).

In panic, I used (for the first time though) adb from a guide on this forum, and copied recovery.img , and now when I enter recovery mode while connected to my PC, I get a 0.99GB recovery partition. When I copy an update (tried 4.5.4 and 5.1.5 also), and to the update, I still get stuck in bootloop (flyme icon).

Any ideas/suggestion what should I try to get my phone working? Thanks in advance.

0

How long did you wait when for it to loop. It sometimes need to take longer. Which firmwares are you at and downgrading to? Unlocked bootloader, get a custom recovery and try the custom roms, they won’t disappoint you.

ZHENK

0

I waited for more than two hours.
I was at 5.1.11 or 5.1.12 I think, and trying to downgrade to 4.5.4.

When I start the phone now, it has the old meizu logo (which is on 4.5.4), but after that, it’s still stuck on the flyme logo.

0

Any chance you could give me a link to adb guide? So i can check what you have done. And have you replaced the recovery.img with another, through fastboot, need unlocked bootloader ofcourse.

ZHENK

0

Thanks for the replies!

I’ll try to find the guide, was on incognito mode so browser didn’t save history :(

I remember doing the following:

I installed adb, and copied a recovery.img to adb folder. I know I entered fastboot (power and vol-), and then I typed in the command prompt something like “adb recocery recovery.img” I think. And then I got the 0.99GB partition. I copied the update.zip to that partition and tried to install, and got stuck in bootloop again.

I’m downloading a custom ROM now, will try it, and see how it goes.

0

Make sure you have a custom recovery. The custom recovery cannot install official meizu firmware.

ZHENK

0

I’ve tried to flash custom recovery, but I failed. Here’s what I did:

  • downloaded “TWRP_3.0.2_M2M.img”, and placed it in the adb folder.
  • connected phone to PC, started in fastboot.
  • typed “fastboot devices” in the prompt, got:
    “88UKBMD224PJ fastboot”

Next, i typed: “fastboot flash recovery C:\adb\TWRP_3.0.2_M2M.img”, and got the following:

sending ‘recovery’ (15082 KB)…
OKAY [ 1.451s]
writing ‘recovery’…
FAILED (remote: download for partition ‘recovery’ is not allowed)
finished. total time: 1.454s

I don’t know if my bootloader is unlocked, so then I typed “fastboot oem unlock” and after pressing vol+ got the following:

(bootloader) Start unlock flow
FAILED (remote: Unlock operation is not allowed)
finished. total time: 5.960s

Any ideas what am I doing wrong?

0

You cannot unlock meizu phones through fastboot. This is why i emphasized that you must have a unlocked bootloader. It is a bit late but here, https://forum.meizufans.eu/topic/5242/full-how-to-meizu-m2-mini-root-adb-unlock-bootloader-twrp-recovery-and-cm-12-1

ZHENK

0

I hope by “it’s a bit late” you don’t mean there is no more hope for this phone.

I’ll see what I can do with that guide (if there is anything that can be done now that is).

Thank you again for the replies!

0

Don’t run out of hope. Try installing the newest beta verison, if you tried every other firmwares. :D keep track which firmwares you tried.

ZHENK

0

Just an update: After no luck in installing multiple versions of Flyme, I found out that there is an official Meizu service center in my country. I’ve sent them the phone, and 3 days later I received it back wiht 5.1.9.0Y, working. The repair was $20 thought, but certainly better than buying a new phone.

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.