Change Smart Voice from Chinese to English (Google Voice)

Re: Smart voice in English
Re: Flyme Os Smart Voice in English?
Re: how to replace smart voice with any other app

My new M5 Note (Flyme 5.2.11.0A) arrived with the default action for “Hold the home button” set as opening Google Voice Search . This was great! However it was a modded firmware from Aliexpress, so I did a clean install and upgraded to 5.2.11.3A. This returned the function to Smart Voice (only in Chinese).

After a little bit of tinkering I have managed to restore Google Voice Search as the default action for long pressing the home button.

This is for the A firmware set to English. Requires root.

  1. Get root, and install SuperSU, Link2sd, System App Remover, and a file editor (I used Solid Explorer).

  2. Grant the above apps root permission, then use Link2sd to convert the Google app to a system app - long press the Google app and then click “Convert to system app” (I also did this for the rest of the Google apps, but that may not be necessary). Reboot your phone.

  3. Use System App Remover to uninstall Voice Settings (the iflytek app). There is no need to uninstall Smart Voice too.

Before you do the next step, make sure that the Hold Home Button setting in Accessibility is set to “Smart Voice”. This setting will disappear after the next step.

  1. Use Solid Explorer. Go to root > system > build.prop
    You need to find the line which says:

ro.product.locale = zn-CH

and change it to

ro.product.locale = en-US

click the save button. Reboot phone.

Google Voice Search in English should now be working when you hold the home button.

I have only tried this for English, and for the M5 Note (Flyme 5, Android 6.0), but it may work for other languages and other devices. All the steps are reversible so give it a go.

Hope this helps someone.

I tried it again without Google as a system app, and it still works.

I think all is needed is to install Google app, disable/remove Voice Settings, and then change region in build.prop.

@Rey Sure! Hopefully some other people are able to verify it worked for them too.

It worked perfectly on my Meizu PRO5, I’m using Flyme 6.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.