Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

Help I can't root my MX4 PRO 5.1.10A using kingroot

0

Please help - I bought a phone from ebay and the flyme account is locked therefore, I cannot root it by going in to the account. I have sent meizu an email asking for help, but not received any response. I have tried desperately to root this phone using kingroot but no matter how many time I try it says failed. I don’t get it? - It appears that many people have rooted their MX4 PROs but why can’t I?

I have stumbled upon your site and I have read a lot about this phone and I am contacting you as a last hope. The details of my phone are below:

  • Meizu MX4 PRO

  • Firmware is 5.1.10A

  • Android Version is 5.1.1

  • Baseband is LTG_3.117.003

Can you please help me root this phone?

0

Meizu officially stated, that they won’t help with these kind of requests anymore as it seems that some devices were unlocked even though they were stolen.

As far as I know Kingroot worked on older firmware versions, maybe try that. However, I would recommend you to return the phone and file a PayPal claim or credit card chargeback (depening what payment method you used).

0

Hi

Thanks for the reply - I am now rooted and I have just changed the phone from chinese to intl.

Can anyone link me to a custom recovery?

0

@verachion I am sorry, but I do not give support to devices, which could be stolen.
Please do not take this as a personal offense, but I wouldn’t feel comfortable doing so.

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.