Has MX4 booloader locked?

Hi guys

I am an freelance and i love being modifying everything of FLYME 4.0 but i cant do it and i dont know why happens this.
I got so many tools for decompile and compile android files apk but it didnt work any tools.

I would to know if mx4 has FLYME locked for developers or something.

Bootloader is only open at international version of mx4

Contributor

It is usually assumed that the International version has an unlocked bootloader.
But one guy has bricked his international mx4 trying to write a custom recovery and claims fastboot and sp flash tools do not work.

So not really sure if the bootloader is unlocked. CN version is definitely locked.

However you should be able to modify individiual apks with root… What exactly is the problem?

HI again and thanks for everyone

I usually use apktool for decompila android apk files but when i try to do it i get errors everytime

My tool for decompile is this(apktool)


But when i try to decompile some files as Settings.apk or SystemUI.apk i get errors everytime and i dont know why.

Can you guys decompile files without problems?

Contributor

@FERNZ, have you installed the mx4 framework files?
Also What exactly is the error?

@‘GreyGhost’ said:

@FERNZ, have you installed the mx4 framework files?
Also What exactly is the error?

Hi bro!

I get the framework-res and mediatek-res of own ROM FLYME 4.0.3 , so i guess theses framework files are fine.

When i get to decompile files as framework.apk or mediatek.apk or whatever app on Flyme 4.0, i don’t get anything, JUST errors and more errors of APKTOOL and others tools for files APK.

Do you know if MEIZU or Mediatek has some special tools for decompile files of this ROM?

So, what i need to know is how can i get decompile files of this ROM?

Is it not because the system files are odex dependent, That might be why.
Never had to decompile a odex file before, might need to convert the system to deodex

More info here:
http://www.addictivetips.com/mobile/what-is-odex-and-deodex-in-android-complete-guide/

@‘punkmonkey1984’ said:

Is it not because the system files are odex dependent, That might be why.
Never had to decompile a odex file before, might need to convert the system to deodex

More info here:
http://www.addictivetips.com/mobile/what-is-odex-and-deodex-in-android-complete-guide/

I know what you say but i tried also deodex FLYME 4.0 and i get erros too and i dont know why that happens.

With the same tool i could deodex other android ROm, However i cant do it with FLYME and that is very weird right.

Contributor

@punkmonkey1984,
Even if it isn’t deodexed he whould not get errors…

@FERNZ,
I don’t have a MX4 but I just extracted the files from the update and I was able to decompile Settings.apk just fine with apktool 1.5.2
Delete your old framework files from other devices and reinstall the meizu ones once again and try…

@‘GreyGhost’ said:

@punkmonkey1984,
Even if it isn’t deodexed he whould not get errors…

@FERNZ,
I don’t have a MX4 but I just extracted the files from the update and I was able to decompile Settings.apk just fine with apktool 1.5.2
Delete your old framework files from other devices and reinstall the meizu ones once again and try…

ok, look this.

I did the same steps than you and look what appears me:

Instead of decompile settings.apk i did with other app.apk

I uploaded the frameworks files and the app files to MEGA.

Can you try to download the files and get to decomilate for yourself? lets see what happens to you

https://mega.co.nz/#!WVMXESRL!jRCnHGlrc2xWBJ6dBRp_UXx9MMnAfMSS2oHCN035pBc

Contributor

@FERNZ,
I used your framework files to decompile Settings.apk just fine…

However the mx4root.apk does give that error… Is that even a meizu apk?

@‘GreyGhost’ said:

@FERNZ,
I used your framework files to decompile Settings.apk just fine…

However the mx4root.apk does give that error… Is that even a meizu apk?

Hi again, that app is an app put out of this italian forum

http://forum.hdblog.it/index.php?/topic/38708-app-flyme-root-hdblog-ver/

I just wanted translate to my language, spanish, for get that i needed decompila the app

I guess if he could make that app, i guess that i might also get decompile the app

Contributor

@FERNZ,
I’m not really sure about what’s wrong cos I’m no expert at it… But if you are able to decompile the mx4 settings.apk then your setup is fine and i guess something to do with that particular apk…


@FERNZ,
But if all you want to do is translate then you can try:
'apktool d -s mx4root.apk’
This will not try to decompile the source code to smali (-s) but should give you only the resource files where you can edit the xml files…

No guarantee that it will work… But worth a try…

@‘GreyGhost’ said:

@FERNZ,
I’m not really sure about what’s wrong cos I’m no expert at it… But if you are able to decompile the mx4 settings.apk then your setup is fine and i guess something to do with that particular apk…


@FERNZ,
But if all you want to do is translate then you can try:
'apktool d -s mx4root.apk’
This will not try to decompile the source code to smali (-s) but should give you only the resource files where you can edit the xml files…

No guarantee that it will work… But worth a try…

That works perfectly


Then i get this folder.

the question is can I compile the apk file once I finished the modification of the language? and get back one apk

Contributor

@FERNZ,
Yeah it should…
You see the ‘classes.dex’ file? That has been copied as is from the apk without decompiling and when you rebuild the apk it will be copied as is and so your apk will work same as the original one… Unless you make some mistake while editing the xmls…

PS. If that is Superuser by koush/cwm doesn’t it already come translated into spanish?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.