Hi, i am using the mx4 now for the past 1.5 but i have never tried upgrading its firmware yet.
I am currently using flyme version OS 4.1.71, can i upgrade it directly to the latest version 5.1.11.0 or do i have to upgrade it to older version first?