Build.prop problem

Hi,

i wanted to change the DPI from 480 to 300 then i get a “Process com.android.systemui ending” in loop. I can’t change back the build.prop and the only way i could recover my phone is doing it by ADB.

The problem is that my phone is not recognized by adb commands (and i’m sure ADB is enabled on it). Could someone give me his ADB Driver for MX4 ?

Alright, from now i’m being very sad :(

Im still stuck in that loop, but i tried to clear cache (thought it would restore default build.prop).
So, now i can’t put my phone in debugging mode (sometimes, i can navigate on the phone like 1/2 min (with the loop still on) but it blocks me after)
and ALL i can do is seeing the Android looping…

I have access to fastboot (my phone is detected) and all of its commands but not ADB, even in recovery.
My build.prop.bak is there but i have no idea i can put it back to make my phone works once again…

Some help would be great :(

Contributor

Clearing cache will not help build.prop
Simply flash the update.zip package of firmware you are using through the recovery (use vol up+ power to boot into recovery)
You need NOT select 'clear data’
If you still end up looping then try with clear data (you will loose your app data but files in sdcard should be fine)

I tried yesterday, but it says “Missing android-info.txt” and it just doesn’t flash… :(

edit : And i can’t flash it, as it’s not anymore on my phone, only have fastboot access :/

edit2 : Putting the update.zip in recovery partition is a good idea but now i get a “file corrupt” in the recovery :/

Could it be a bad download? It’s pretty common try with a new download and verify the controlsum


Ain’t there no supporttools for mx4, most companies do have some kind of public or leaked tools?

I downloaded it here so many times… It’s a China Mainland version, as i saw it’s need a “special” update.zip. I could have save it from my phone but deleted it (thought i could download it here).
Someone in Flyme 4.0.3U could give me his update.zip ?

You can download from Meizu China I think.

Contributor

@Smoogie,
If you have china mainland version you should get 4.0.3A from here:
http://meizufans.eu/forum/thread-flyme-os-4-0-3-stable

(meizufans servers give much faster download speeds than meizu official servers)

To see if the file downloaded correctly check md5 sum here:
http://bbs.flyme.cn/thread-23511-1-1.html

@greyghost, are there any external supporttools available?

Downloading 4.0.3A version, i’ll try to install it this way :

1/

  • Put it in the recovery partition (E:)
  • Boot in recovery then select update

if it not works, i’ll try :

2/

  • start in fastboot mode
  • fastboot update update.zip

But to be honest, i’m losing hope…

I thought ADB works naturally in recovery, i still can’t find my phone with adb in recovery :(

Contributor

@Smoogie,
Method 1 should work. If you were only changing the recovery there is no reason for it not to succeed…
Don’t try 2 unless you know what you are doing. Read below:

@zztop007,
Well no officially released tools. There is already one guy who has bricked his device trying to flash a custom recovery. He claims fastboot and sptools don’t work. I can’t really confirm amything as i don’t have a mx4…

IT WORKED !

OMG I love you so much GreyGhost !
Method 2 did just not work but doing it by recovery is good.
The problem is that i DONT understand why the 4.0.3A worked, when i thought my phone should have received 4.0.3U.

Anyway, i’m now recovering my apps now :D

Contributor

@Smoogie,
No problem…
A- is mainland china this is best to use if device is not international model and can be installed on all models
U and C are china unicom and china mobile (phone carriers there) so they have some network specific stuff and network boot logo etc…
I - international version (same as A but without chinese apps which you can unisntall frim A anyway)

Great job, and thanks.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.