Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

Battery and speaker problems

Hello everyone!
I have 2 problems with my MX4, so can someone help me? :

  1. Problem with speaker when i’m calling someone, their hear me, but i can’t. It’s working when i put headset or enable speaker. This problem persist about 1-2 months. After i decided to buy a new speaker from aliexpress, but when i replaced it, nothing changed… Maybe it’s from firmware? Because i noticed it started about when i upgraded it, now i have(5.1.5.0G, before i had A version). What should i do? (or should i try to downgrade to a older version, or to upgrade to 5.1.11.0G)
  2. I have a problem with my battery, sometimes it’s decreasing to 0 momentary, or when charging it’s going too fast to 100%. I tested the capacity once and was (2850 from 3100 mAh)
    0_1479911075193_S61122-130134.jpg
last edited by justkid
Admin

Redo the upgrade with clear data. However, load the device up to 100% before doing so. This way the battery stats will be reset.

The problem is that i can’t remeber which of version was.
Or it doesn’t matter?

@justkid it doesn’t matter just try to reflash with clearing data

It’s writing “Firmware corrupt” no matter what version i try to install(4.2.8.2A or I and even latest 5.1.11.0G). Help me please.
PS: I converted A version to G using Method 2 from here (2 months ago)

last edited by justkid
Meizu Pro 5

@justkid You need to apply a “A” version. For example 5.1.5.0A

Hey, I have the same problems too.
I used be on the latest beta. Something happened and I had to install a firmware with clear data, so I chose 5.1.11.0 version.
After that I experienced some problems with speaker like you do, but I think (I am not talking much) it is fixed now. Also about the battery, firstly the phone turned off about at 30%, then 40%, then 60% and now 70%. I checked with an app that there were few broken cells, but the app supposedly fix them. I tried to calibrate the battery with and without root through another app and I saw no much improvement and after a while the same thing. So I thought that the battery broken, beacause I used it quite much. I am thinking of buying a new one from aliexpress, but now with your similar case thinking that maybe its something with the firmware. Now I am on 5.1.11.1.
What do you think guys?

Hi
Same problem too, but ionly about the speaker affair. I disassembly the battery and plastic inside to check the loudspeaker, but i saw nothing strange. So i’m pretty sure that all’s about firmware. I was in 5.1.11.0 too, and problems began with the last upgrade…sometimes speaker sounds, sometimes silence…and some strange things like camera doesn’t open sometimes, and little blocks…
I 've reset to factory, and it’s a little better, but now there’s sometimes a delay…i touch the screen, or write something, and the sound comes 2 or 3 seconds later…
Now i gonna try to downgrade to some old stable fiirmware…and i’ll tell you what happens. i hope you’ll do too.

I noticed that the speaker problem remains to mine too.
About the battery the problem is getting bigger and bigger. Around 80% the phone powers off. I saw that other people have it too and that shows that it is something about firmaware, otherwise as we are doing different use of the phone, we wouldn’t have experienced this problem at the same time. And the thing is that, even if it wasn’t a software problem, I am charging the battery 3-4 times per day and this can destroy it.
I thought about factory reset or downgrading the version, but I did that (downgrade) before those problems appeared and I have fulled the phone with apps, so that it could take me a lot of time to install them again. But if you guys do it please let me know, beacause its the only thing we can do waiting for a fix.

@Kikounet95 I put A version instead of G, but problem persist when i try to downgrade to 4.2.8.2A, “Firmware corrupt”.
Anyone?

i finally did the downgrade to different firmwares, reset to factory, and disassembly again, but nothing changed. Finally i’d go to a repair store, and they changed the loudspeakers, of course nothing changed,…and they tried to change the subplate…the problem remains. I don’t know what to do, and the boys in the repair rervices either.
If somebody knows something, we would appreciate the contribution!.

Same problem with the Battery too. Drops at 40% to 0%…but i can switch it on after a few minutes and then it stays on for an hour…can do this a few times.
Reset and clean install of firmware didnt change thing.
Sorry for bad english :D
0_1482083698253_S61218-185228.jpg

Looks like your connection to Battery and speaker problems was lost, please wait while we try to reconnect.