Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

Can't downgrade from 5.1.5.0A

Hi guys! I’m stuck on Flyme 5.1.5.0A. Tried to install 4.5.7A and 4.5.6A it says “Firmware corrupt”. Also can’t upgrade new version. Can someone help please? I want to return international flyme because i need bulgarian language. It was on it. My MX4 is from TCCM. I’m worried if i can’t return it back.

Meizu Pro 5

Looks like your connection to Can't downgrade from 5.1.5.0A was lost, please wait while we try to reconnect.