Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • SoftBrick MX4 Pro


    Hi all, I’ve recently tried to change my Chinese ROM to an International one. I misjudge the moment where I had to reboot and now when I boot up my phone it gets stuck on the MEIZU logo.

    I can go into recovery by holding down the power button and the + volume button.

    I’ve done some research and see that there was a way to fix this issue.
    I tried to follow the instructions from this site: https://forum.meizufans.eu/topic/6775/firmware-not-found

    Although I wasn’t able to put the file onto the phone. My Ubuntu (16.04) machine sees the Meizu phone but I couldn’t mount it.

    Please tell me if I left out any relevant detail.

    If you guys could help me resolve this issue, I would greatly appreciate it.

  • Try using an USB 2.0 port instead of a 3.0 one (if that is the case). I noticed issues with the drivers on 3.0 ports (at least for me).
    Also try a different computer maybe (unless your Ubuntu machine isn’t seperated).

    Meizufans on Facebook
    Meizufans on Twitter
    Meizufans on Google+
    READ THE WIKI FIRST!!!

  • Thanks for the reply, Rey. I’ve tried on a USB 2.0 Port still got the same issue. I’ll try it on a windows laptop, but that’ll take me some time to set up. I’ll keep you posted.

Posts 3Views 160
Log in to reply

Looks like your connection to SoftBrick MX4 Pro was lost, please wait while we try to reconnect.