Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • can't install Google services on my meizu mx4 pro


    hi guys. i just got my new Meizu mx4 Pro delivered from China last week. everything is working fine, except for my inability to install Google based Apps on it.

    on the app center, I’m trying to install Google Installer, but the installation bar is stuck on zero percent.

    i can, for example, download the Gmail app, but then when i try logging into it it says ‘this app needs Google play services which aren’t installed on your phone’ and the app shuts down automatically…

    i tried to reset the phone on its manufactur definitions, but this doesn’t solve the problem.

    i read online that an .apk file of the Google play store could help me, but i didn’t manage to pull it off by myself.

    fwiw the Android version of the phone is 4.4.4

    i would really appreciate your comments on this one, as it kind of driving me crazy by now.

    thanks a lot
    Nir

  • First of all, I would recommend you to upgrade your firmware to the newest stable version. How to do it, please read here https://wiki.meizufans.eu/upgrading-and-downgrading/upgrading

    Then you should try to install your google play services using Google Installer from Apps Store.

  • Google installer may be a bit slow but that’s the best way to achieve your set up. Amount of data is use so prefer Wi-Fi rather than data…

    Meizu PRO 5 4Gb | ID changed, rooted & running latest G build (beta) + Xposed + TWRP

  • problem solved. thanks a bunch for all of you :)

  • … A quick sidenote:

    my laptop doesn’t recognize the phone when I hook them up with a USB cable.
    the problem isn’t in the laptop as it recognizes my other phone…

    any suggestions?

    thanks again

  • @nirshoham, try to check and change how is your phone connected to PC. Go to your phone’s Settings > About phone > Storage > Connect as and check Media device (MTP) if there is something else checked. Then just try reconnect your PC cable. If nothing change try to change different options like PTP, CD-ROM and always reconnect your cable. Does it help?

  • @nirshoham Hi guys, I have meizu m2 note. I am also facing the problem that when I tried to log on to the google account it shows that"Checking info",It is not asking me to enter my login id or password and though my google play store is also not running, whenever I open the app it shows that"Checking info"and again the same problem is happening. What should I do to fix it?

  • @yash.cola I’m not sure if it’ll help, but you should try to clean memory/data/cache at least of following google apps: Google Play Store, Google Play Services and Google Services Framework.
    To do this you should go to your Settings > Apps and find the apps described above. Then click each of these apps and then on ‘Clear data’ or ‘Manage space’ in case of Google Play Services app, and clear all of your data. Then try to reboot, however I’m not sure if it’s necessary. And then check if your Google apps working after all.

  • @nosmos

    the laptop still doesn’t read my phone on the USB.
    when i connect it via USB it says “installing hardware…” and then immediately “the hardeware for this device failed to install”.

    could I find such hardware on this site?
    it seems like something is missing in my phone… like the USB program or whatever it’s called

  • @nirshoham are you connecting on windows machine? And do you have USB / adb drivers for MX4 Pro installed? If not, try to install them and check again.

Posts 11Views 747
Log in to reply

Looks like your connection to can't install Google services on my meizu mx4 pro was lost, please wait while we try to reconnect.