[GUIDE] RECOVER a MEIZU M3 from BOOTLOOP (meizu logo and constant reboot)

Yeah. Finally I did it !
Recovered the damn M3 from the bootloop (no recovery menu, no flying ballon, just MEIZU LOGO and constant reboots).
It is NOT a trivial process, but I’ve tried to detailed the best I can so it may help someone else with the same problem:

Everything you need (except the phone and a proper cable) are in the link bellow.

= MEIZU M3 RECOVERY:
The objective of this guide is helping in Meizu phone recovery stuck in a BOOTLOOP with ONLY MEIZU logo visible.
In specific context is for the meizu m3 (also called m3 mini) running with a Mediatek MT6750 chipset.
With this guide, 2 sub-folder are included:
= MEIZU_M3_MT6750-scatter_rom_auth - with m3 specific SCATTER and ROM files;
= SP_Flash_Tool_v5.1636 (auth file) - Flash software tool

THIS GUIDE IS SPECIFIC FOR MEIZU M3 PHONES WITH THE SPECIFIC SYMPTOM DETAILED IN THIS GUIDE.
I TAKE NOT RESPONSIBILITY WHATSOEVER FOR WHAT A USER MAY DO.

Symptom:
The symptom we are trying to solve with this guide is when the phone is stuck in a bootloop.

  1. The bootloop shows the MEIZU logo then the phone turns off and on again.
  2. The phone CAN enter fastboot mode (keeping power and vol- buttons pressed together) but it is not possible the flash anything as the boot is locked by meizu.
  3. The phone CANNOT enter recovery mode (keeping the power and vol+ buttons pressed together) and so it is not possible to normally flash the firmware.

Shutdown the phone stuck in a bootloop:
To shutdown the phone keep the power button pressed and wait for 2 bootloops. At the second power off (meizu logo disappearing) immediately release the power button.

Get the phone out of the bootloop
This is a set of several steps to be made. I was able to recover my phone by doing all this steps, I cannot confirm if it will work for every phone and if all the steps are needed:

(CREATING THE SPECIAL CABLE IS NOT REQUIRED. IT IS KEPT IN THIS GUIDE AS A REFERENCE)

  1. Make a specific USB OTG host cable:
    In summary:
    A. Pickup a micro usb to usb cable;
    B. Disassemble the connecter and solder both 4 and 5 pin together;
    C. Most cables have 5 connectors in the phone side, but only 4 wires inside the cable, so the connector must be disassembled.
    There are many guides on the net for this, in the following list there is an illustration and some helpful links on how to do it:
    ![alt text](image url)

Easy guide:
http://tech.firstpost.com/news-analysis/how-to-make-your-own-usb-otg-cable-for-an-android-smartphone-29503.html

Simple video guide in youtube:
https://www.youtube.com/watch?v=dV9Q7xo7FRo

2. Use sp_flashtool (flashtool.exe):
a. Uncompress the meizu-m3-recovery.zip file into your pc;
b. Browse into the uncompress location and right-click the flash_tool.exe file and select “run as administrator”;
c. Go to the menu Options -> connection -> usb full speed with battery;
d. For the download agent select DA_PL.BIN form the “SP_Flash_Tool_v5.1636 (auth file)” folder;
e. For the scatter-loading file select MT6750_android_scatter.txt included in the “MEIZU_M3_MT6750-scatter_rom_auth” folder;
f. Select the “download only” option;
g. Don’t press the “download” button yet – just keep reading;

All included roms should be automatically selected;
I suggest to select and flash one ROM at a time following the order bellow:
• recovery
• m1img
• md1dsp
• md1arm7
• md3img
• lk
• lk2
• tee1
• tee2

3. Write each rom in turn:

Keep the phone powered off – IF you cannot power off the phone keep the phone power key pressed down, count 2 power-offs, at the second power-off immediately release the power key.
If this doesn’t work, try going first into fastboot mode by pressing power and vol- keys and wait for 2 or 3 reboots until the phone stops at the fastboot menu. When this happens, press the power key until the phone powers off (release the power key immediately after the screen goes black).

Press the download key on sp_flash_tool;
Connect the usb cable to the phone BUT NOT TO THE PC!
Now, pay attention: Press the power key on the phone. Once the phone vibrates IMMEDIATELY connect the cable to the PC.
Wait …
A yellow bar should display in the bottom of sp_flash_tool window
….
The phone should power off and turn on again, the ROM should be loaded into the phone, the phone powers off, wait 1 minute ……… “OK” should be displayed by sp_flash_tool !

Disconnect the cable from the PC.

Repeat the process for each rom of the above list.

4. Flash the BOOT rom

If everything worked ok for all the roms in the list we should now do it for BOOT.
After flashing the BOOT rom (following the procedure detailed before) the phone SHOULD NOT power off, but it should enter in boot mode displaying the typical flyme rotating BLUE BALLON 
Wait for about 10 minutes …
… Sp_flash_tool should report an error, but the phone will eventually start optimizing apps opening the way for a normal boot!

5. GOOD LUCK :)
And don’t forget to post your results
;)

Kokotonix

= Instructions, SP Flash TOOL and ROMS available here:
https://www.sendspace.com/file/9lr2u4

:::

spoiler text

:::

last edited by kokotonix

Wow that did the trick! Thanks man!!! :D
We only lost the multilanguage. We only have Chinese and English right now. I tried to do a update and that worked but it doesn’t add the multilanguage. I also tried to flash a different boot.img but that’s not working. Do you have multilanguage?

Great to know it worked for you too :)
[I bet this approach will work for other recent meizus, providing they use the proper scatter and rom files (MEIZU_M3_MT6750-scatter_rom_auth folder must be completely different)]

Anyway, and focusing in “our” M3 :

Meizu M3 doesn’t have an official multilanguage rom in its site (mine came with a gearbest fake multilanguage version).
But there is a simple way to activate other languages:

  • Configure english language and your geographic location in your phone.
  • Install morelangs from google playstore:
    https://play.google.com/store/apps/details?id=sightidea.com.setlocale
  • Activate usb debugging mode in your phone and connect it to your pc.
  • In your pc you need adb installed and use it to give permissions for morelangs to change your language. For doing so run this line in your pc command line:

adb shell pm grant sightidea.com.setlocale android.permission.CHANGE_CONFIGURATION

  • Execute morelangs in your meizu m3 and select your language.
  • Every app should automatically detect your language except android settings and notifications that will remain in english.

-Question:
You recovered you meizu using the proposed special cable or a standard one ?

last edited by kokotonix

Hello, kokotonix! I have Meizu MX4 with the same problem. I have done the first step (making cable). Now, I can not find ROMs for my phone. Could you tell me where to find it? :)

@igorbvik said in [GUIDE] RECOVER a MEIZU M3 from BOOTLOOP (meizu logo and constant reboot):

Hello, kokotonix! I have Meizu MX4 with the same problem. I have done the first step (making cable). Now, I can not find ROMs for my phone. Could you tell me where to find it? :)

Sorry man. My experience is just with M3.
What I can suggest you:
go to gsmarena and find out the chipset of your MX4 - if you’re lucky, it will be one of the 3 for which I’ve included the scatter files.
If so, copy the scatter file to a new folde - if not, you’ll have to search SP FLASH TOOL scatter file for your chipset.
Then you have to pick up an update.zip (firmware) file for your phone and extract the ROM files with the same names as the ones I’ve given for m3 but always respecting the names they have in the scatter file.

Be carefull: Only use the scatter file and roms for your device or you’ll have a permanent brick !!!

Good luck

By the way, I didn’t need to make a special host cable. I also works with just a usb cable… Haha ;-)

@Migha128 said in [GUIDE] RECOVER a MEIZU M3 from BOOTLOOP (meizu logo and constant reboot):

By the way, I didn’t need to make a special host cable. I also works with just a usb cable… Haha ;-)

That’s great. I will update the guide and strikeout the need for the special cable.
So, it seems the ultimate trick is to connect the phone to the pc immediatelly after the power up.

Well … In fact … I really don’t care where or what is the trick:
what is really important is that IT WORKS AND I HAVE REVIVE MY MEIZU M3 ! ! ! ! !
:D :D :D

Meizu m3s

How did you get the auth file??? i need one for m3s

(It should be the same scatter file):

As m3s has a mt6750 based chipset, it should probably use the same mt6750 scatter file as m3.
You can validate, (at least the starting offsets) before venturing further, by looking into the scatter.txt file that comes with any official m3s update.zip firmware distribution and cross referencing it with the scatter file I have provided with the guide.

Meizu m3s

I have noticed that the sizes are the same with the scatter file but i am still getting this error
status_brom_cmd_send_da_fail(0xc0060003)
when using sp flash tool, instead of a yellow bar.
I was wondering if it was the problem of the auth file?

Have you followed the guide on the first post, EXACTLY as described ?

Meizu m3s

yep. i reread all the step and guess what, i forgot to select "DA_PL.BIN"
I have done everything from step 1 to 3 with images of my phone i backup.
but i am not successful on step 4.
The phone did not boot to typical flyme rotation, i guess i might try with different images.
I will report back if i success XD.

Meizu m3s

Success, yay my phone is back!!!
Thank you for all your help!!!

"problems i faced"
stuck at flyme logo
connect to pc, type adb reboot recovery (make sure you have recovery flashed)
download update.zip to removable device (recovery)
install update.zip

the m3s also works with this method with .img from update.zip!
Time to help more people with this problem!
Asking for permission to repost this to xda to help more people

That’s awesome!
Thanks for the report.

You are free to share the method with others, but please refer the original source and author and a link to the first post.

Regards

OK, I found a way to get back all the international languages on the Meizu M3 mini.
Kokotonix, again thank you very much for the solution to unbrick. Now here is the trick to get back the languages:

  1. Download the following file: https://drive.google.com/file/d/0B_sbcNUJWi9ZVXY1QXlURUs4V00/view?usp=sharing
  2. Power off the Meizu and open Flashtool. Use the scatter file provided in the topic of Kokotonix, so NOT use the scatter file inside this zip file I shared with you.
  3. Now pick the system.img provided in this zip file and click on the Download button. Then connect the Meizu to your PC and it will flash the system.img file to your device. When done, power on your Meizu and go to settings. Now you will get all the languages!! :slight_smile:

Done!

last edited by Migha128

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.