Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

Upgrading Flyme on M2 mini

Hi, I bought an M2 mini from aliexpress. It is an international version and supports OTA.
Current Flyme version is 4.5.4i.
Can I upgrade to Flyme 5.1.6.0G, or will it ruin the phone?

Thanks

Looks like your connection to Upgrading Flyme on M2 mini was lost, please wait while we try to reconnect.