Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • Tomtom Go Can't connect to tomtom server


    Hi

    I tried to install Tomtom Go from Google play and when I start it up I get an error that says:
    “The app can’t connect to tomtom. Please check your device internet connection”.

    Has anybody been able to install Tomtom Go with the latest firmware 5.1.9.0 A ???

  • Nope. I’ve tried with all the versions available and Tomtom doesnt work. I can install it but when I start the app it tries to connect to Tomtom Servers and it cant.

    To make things weirder, I had it installed on my phone before, I think I did around 5.1.7 and I had no problem…

    Something has changed, or maybe something is left in the memory of the phone when you uninstall it…

    :-(

    I guess no tomtom for me… It’s the only application I had problems like this…

  • @freaker I have Tomtom installed since 5.1.6 A and everythings is fine even now on 5.1.9 it’s works good
    But it’s an older version …

  • after trying a lot of things I gave up.

    I installed Sygic with no problem at all…

    Before that I installed a traffic sniffer on the phone to see what was Tomtom sending through the net and it showed a crash dump that was sending to a crash dum service. So it seems that doing some internal operation it crashes when it’s starting up.

    I read on a few forums that there are problems with tomtom go when you try to install it on chinese phones due weird serial numbers. I ignore if this is the case…

    regards

Posts 5Views 438
Log in to reply

Looks like your connection to Tomtom Go Can't connect to tomtom server was lost, please wait while we try to reconnect.