Actually had a 5.1.3.2G version, flashed into 5.1.6.0A then to 5.6.9.6A test
But now i’m unable to downgrade to any previous firmware (Firmware too old)
Any advice?

last edited by neekz