How to activate LTE connection?

I have Telia which support LTE FDD bands 2600, 2100 and 800mhz.
But I am unable to connect to LTE network. Dataconnection is set to 4G Priority.
I know there is LTE connection in my area.

Anyone else having problem with European LTE connections?
I have purchased the international version, firmware 4.0.2l

I have also tried a varoious of 4G switcher apps, but even when forcing on only 4G there is no connection.
Maybe all this is due to an firmware issue, if anyone could confirm this problem it would be of great help.

Regards,

Markus
Sweden

Some carriers have a special LTE APN entry you may need to manually add. Mine wasn’t there…I had to add it myself and then it worked.

The APN is correct I’m afraid. Used the same APN with my HTC One and 4G works there.

Sorry, my bad. Telia is using 800Mhz in the area and it is not supported in the MX4.

I guess LTE will work in the city centre where 2600 and 1800mhz is used instead.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.