Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • M3s: an easy method to ROOT your m3s and to switch from "A" (chinese) to "G" (global) FLYME 5 (see below...it is possible!!!)


    LOOKING FOR HOW TO ROOT AND CHANGE FLYME FROM A to G ? SCROLL DOWN BELOW YOU SEE A POST STARTING WITH IT IS POSSIBLE

    Here are the old previous post…
    (old post)
    Hello friends,
    I have a brand new Meizu M3s with firmware FLYME 5.1.5.1A.
    I live in Italy…and I am quite disappointed about this phone.
    I own a Meizu M2 mini too and such phone is far better in getting 3g/4g (LTE) signal (quickly change cells) … I NEED to change my ROM from china to global… I am quite good in modding and changing roms but I cant find a GOOD method to change this M3s rom… can anybody help me?
    I will offer a reward trough paypal account to anybody that can really help me…please!!strikethrough text

  • I would appreciate some help too.
    I’ve tried the methods from the thread “[Guide] How to install (I) International firmware on your Chinese-mainland Meizu.” but I’m not even able to find an option to set root permissions in Settings/Accounts/Flyme. All I can do is allow root permissions for individual apps under Settings/Finger Print and Security/Root but that does not seem to work as BusyBox tells me it lacks the proper permissions while RootChecker says the phone is properly rooted.

    I’ve also tried to downgrade to another Asian Firmware-Version (5.1.5.0A) from MeizuFans by putting the update.zip in the root directory of the phone and rebooting into the upgrade screen (VolUp+On) but even then it says that the firmware is corrupt.

  • Yes… to me its impossibile to get root SU permissions and therefore impossible to edit the script to change from A to G. In details,my prob with meizu M3s is that in Italy, with “H3G - telephone company”, it does not work very well in surfing over internet in 3g/umts/hdspa… I mean …even having a full 3g signal on my phone… it does loose internet connection or cant always send a simple whatsapp message… I think it depends from the FDD band…

  • @faredino2 @gerHun
    If i’am not wrong To get the root menu in settings you should first create a flyme account once it’s done you should see it appear in settings>security> root
    You can manually create an account via the website not especially via the phone

  • I have a fully functional meizu account… Youre not wrong… but your method isn’t valid with m3s… In details I already have the root menu but not the SU access (needed). Thank you anyway.
    Pic 1 = my meizu account
    Pic 2,3 = root access (but not SU access)!0_1472909653863_S60903-153248.jpg
    0_1472909671300_S60903-153208.jpg
    0_1472909684180_S60903-153204.jpg

  • @faredino2 Try to Use super SU not the native root of flyme and install busy box might help

  • SU access is denied… busybox installed and tried but as soon as I launch the app it doesn’t recognize the system as rooted and therefore cannot do anything…thank you anyway, I appreciate.

  • IT IS POSSIBLE!!!
    I JUST DID IT !!!
    M3s rooted and transformed from chinese to international/global!!!
    HOW TO SWITCH FLYME FROM “A” to "G"
    PLEASE READ EVERYTHING TO UNDERSTAND

    1. the premise:
    • I buyed my m3s from an international chinese seller.
    • It arrived to my house with flyme 5.1.5.1A, italian and multi-other Language, Google play installed and perfectly working, no chinese app like app-store, news stand alypay ecc.
    1. the beginning
    • everyone who is trying to switch from A, M or Y (chinese) to G (global) any meizu terminal should now that it cannot be done easily by simply downloading the new (G) rom, putting it in the main directory of the phone and restarting the phone while keeping pressed the vol down + power buttons toghether… this will show a “FIRMWARE CORRUPTED” message…
    • if you want to change the rom from A to G, you need to first execute a script (as I will show you below) that prepare the phone, making it believe itself has “already” installed a G version of the flyme rom… only after this step you can download the G rom and easily flashing it… because the system will recognize the phone as already a G phone and therefore will not block the installation of any G rom…(it will not show FIRMWARE CORRUPTED!)
    • but… to execute that script… you need to ROOT your meizu before…and gain Super User permissions…
    1. the struggle
    • after many reading on how to root a M3s and after many tries…I WAS almost crying because my M3s device WAS not getting rooted in any ways…
    1. the solution
    • ROOT is EXTREMELY SIMPLE EVEN ON M3S…YES IT IS… The problem that I discovered that made my root impossible (until few hours ago) was that my M3s, as buyed from the seller, was showing to have a “flyme 5.1.5.1A” …BUT IT WAS NOT TRUE…simply upgrading my meizu to FLYME 5.1.5.2A (www.flyme.cn) I discovered that the “real A” firmware has not italian language, has not Google play store installed and, on the other side, it has many many chinese app as default apps…so I understood that my phone cannot be routed because my (previous) rom WAS NOT a “normal” “A” version of the flyme 5.1.5.1… (and I still wonder which kind of A rom I was having…???)
    • so …after upgrading my phone to 5.1.5.2A and after getting a real meizu flyme A rom…then… rooting is a 2 simple step away… no software needed … : simply 1) log in to meizu account (under setting, meizu account, create a new one if you dont have) and
      … after logging in, go to settings - fingerprint and security - and you’ll find the ROOT tab…open it… accept everything…the phone will then restart…and YOU HAVE ROOTED IT!!!
    1. the procedure
      once rooted…youre just a few step away from the big final… ok… download the G version (flyme 5.1.5.1G…from here …and then put the file on the main directory of the phone (not the sd card!) - download this script and put it on the main directory of the phone (not the sd card!) … - download this terminal emulator and install it on your phone…

    2. the big final
      execute (open the app) the terminal emulator and write literally:
      su
      and press enter
      and after a short time, when the $ prompt appears again write literally:
      sh /sdcard/global.sh
      after your device reboot, you can simply flash (upgrade) your new “G” firmware!!!

    believe me its possible!!!
    even on m3s!!!

  • This is the solution.
    Unbelievable how easy it eventually was.

    Faredino, you are the greatest!

  • so actually all can be done from the phone itself. Download the G rom to the phone memory , download the script and then download that emulator.
    Rename the G rom to update.zip , open the emulater app and follow your steps.

    I will give it a try on my meizu m3 note.
    Currently on latest A beta OS. Was a global device and came with global rom.

  • thanks for the instructions.

    BTW, can you provide the link to Int’l firmware for M3 Note? I could not locate it on the web. Is the latest 5.1.3.3G or 5.1.6.0G?

    thanks

  • Official global G roms are here
    Www.flymeos.com
    Havent see a G rom for m3note …I own m3s

  • This post is deleted!
  • Does any one know if this method of faredino2 is also valid for meizu mx4?

  • @faredino2 YOU ARE GREAT!
    Thank you very much my friend!Your method was perfect and now my sister’s m3s is global.One thing I have to say,the phone came with 5.1.5.2A from the seller and I installed 5.1.5.2A from meizu.cn over the old one.The rest was just the same.Now I have only one problem.There are 2 Mzaccount icons but only one works.The other one doesn’t work and I cannot delete it either!Thanks again!You are great!

Posts 20Views 3882
Log in to reply

Looks like your connection to M3s: an easy method to ROOT your m3s and to switch from "A" (chinese) to "G" (global) FLYME 5 (see below...it is possible!!!) was lost, please wait while we try to reconnect.