Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

-updated & SOLVED: Chinese M3s (5"screen octacore with FLYME doesn't go on 4g/LTE in Italy

This post is deleted!

@faredino2 I guess that you have double-checked your cellular settings.

But just in case, then check Settings->Cellular Networks->Network Mode. Make sure this option is set to ‘4G first’ and not ‘3G first’.

Meizu MX4, Meizu Pro 6


Thank you the same for your reply…I dont know how and why but the problem now seems fixed.


You must remember that Meizu M3s doesn’t support LTE band B20 (800mhz)

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.