Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

FlymeLauncher not starting/crashing

0

SO the basic problem is that the pre-installed FlymeSystemLauncher won’t start. When I boot up my phone the lockscreen still shows up but when I unlock my phone it shows me only my (working) statusbar and a tinted version of my background but the launcher itself won’t start.

I’ve encountered this problem before on my Pro 5 (rooted and running Xposed apps). I’ve fixed it by completely reinstalling my Flyme version (5.1.6) and then i upgraded to 5.1.8.

Now that i’m on 5.1.8 i re-rooted the device and installed xposed again and everything was working fine and i don’t think i did something to trigger the crash or something like that.

With using adb I disabled root and all running xposed apps but my launcher still isn’t working.

I also pulled the Launcher apk from the phone to reinstall the launcher manually through adb which again didn’t change anything.

I suspected that maybe the Xposed app flymeTools was at fault but since it’s deactivated that’s probably not it either.

I’ve also checked what logcat tells me about the Launcher when I try to start it and this is the log I got: https://mega.nz/#!9o1xTKJJ!NdPC-ulyMO-xM3VPpE9DfV5JZfoje3CNXpR7mVFS6WM

I’m really hoping you can help me with this problem and thanks in advance for any response to this post.

0

So if no one can answer me I’m just going to do it myself.

So i re-installed Flyme and then checked if the launcher still crashes without Flyme Tools installed for several days while making a daily adb backup. It was working without crash for 4 days so I decided to install Flyme Tools again and guess what? It crashed the day I installed it after a couple of restarts.

The thing that confuses me is that I set up the settings before even activating it in Xposed, then I restarted it and the Flyme Tools settings worked. But after about 5 or 6 restarts it the launcher crashed without me changing the Flyme Tools settings.

So my question is: Why is there a restart delay until it starts crashing?

The log I provided shows something along the lines of: “Flyme can’t access this memory byte” or something like that ( I’m not that good at understanding this log so it may be something else entirely ).

So my guess is that Flyme Tools just modifies something that much until The System Launcher is not able to handle it anymore.

If someone has the same issue just re install Flyme and stop using FlymeTools.

So my second question is: Is there something along the lines of FlymeTools that I could use? And if someone has the same issue do you know which option may have caused the Launcher to crash.

I’m also using FlymeTools 2.6.8.2163 (translated verison of course) so if that’s the issue i’m going to update this thread again so that others know better.

1

Thanks for the asking/responding monologue! :P
But seriously, i’ve been using flymetools a lot w/o problems… but of course… i use Nova Launcher… hate io’ish look.

0

Built in launcher isn’t the best one. Matter of taste obviously but you may look for alternatives

Meizu PRO 5 4Gb | ID changed, rooted & running latest G build (beta) + Xposed + TWRP

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.