Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

android 6 or 7

why don’t meizu make flyme with android 6 or 7, I think it is better than 5.1.

Admin

@tkn we all know that a newer OS is better and more advanced, but Meizu is simply not capable to provide proper firmwares. Even if they will update Flyme 5 to Android 6 (only available for Pro 6 and MX6), nothing will change for us as they still have their heavy and buggy Flyme UI on top of it.

Looks like your connection to android 6 or 7 was lost, please wait while we try to reconnect.