Flustrated and Feed Up! Need Help plz

Hi Guys,

I am Jay. Here’s my story.

A couple of months back when M1 note was launched I loved the design of the phone and purchased it. Oh I am from India. Well in a weeks time I found major network issues and call drop issues so I returned the handset back with a heavy heart since I really liked it and purchased a Moto X Play.

The day when M3 note was released for flash sale here in India I again purchased the handset hoping that what ever network issues were present in M1 might have been taken care of.

So after I received my M3N with in a weeks time I found lot of issues.

  1. Network issues major network fluctuation, call drops at the places where I never had any issues with my Moto X play.

  2. I have a Sandisk Ultra 64 GB memory card which was working fine right from my Xperiaz Z days in my Moto as well. The 1st time I put the memory card in M3N it started giving error to format. Tried different memory cards as well same thing. Used this memory card again in Moto no issue.

  3. Delayed notification which is like a plague for this handset with just the security app work around. Oh by the way it some time works sometimes it does not for me.

Even after so much headache and pain I thought to continue with M3N as again I liked the design and the performance is ok. So someone told me to shift to chinese A roms instead of Global G roms which come on the Indian handsets.

I did this and initially eveything was ok but againg the delayed notification and memory card issues started so I upgraded to test firmare 5.6.7.26. Its was working smooth and suddenly after only using it for a day in the morning my wifi as well data was gone not connected please check ur internet connection or the phone is offile message.

Now you guys understand where I am coming from. Meizu customer service is a joke have contacted them several time to no avail.

Comining to my point I want to get back to Global rom now and followed the global.sh instructions which did not help me downgrade to global rom.

I also used the flashfire method I was able to downgrade to 5.3.3G however since build prop was for 5.3.2G thats what it shows in about phone.

So I downloaded the correct 5.3.2G now and again tried to flash it with flashfire but no use don’t know why it does not flash it.

What I would like here as help from you guys if you would be kind enough to tell me how to change the recovery back to global and flash the gloabal 5.3.3G to a phone which is alreay global. Since I have been trying to do this for almost a week have read through a lot of websites and blogs so I would really appreciate if you could put in detailed steps and links if any app is required.

If I have offended any one here or if there is any spelling mistake please excuse me I just went on writing what came to my mind.

Jay.

Contributor

Hey!

What’s the flashfire method?

As far as I know: Meizu has a locked bootloader -> so flashfire is no good for you.

What exactly did you do.

I mean I used Flashfire to downgrade to Indian Rom.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.