Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

Can't update meizu m2

0

Hi! I want to reinstall my meizu m2 note , im on flyme 5.1.6 OG .
When i try to factory reset or open update.zip i see this text : firmware corrupt and i cant update or reinstall my device.
I want to reinstall my device so its can be like a new from the box.
Also i have installed Xposed firmware , maybe its because of it?
I want to reinstall my device because i cant find a way to delete xposed…

0

Things are similar but nevertheless there are two phones and two cathegories on the forum, m2 (aka mini) and m2 note.

I’ve had the similar issue on m2. I tried several times to install 5.1.6.0g update.zip from recovery, it always told me that firmware was corrupt. Then I double-clicked from flyme (ie, used the upgrade app), and then that same update.zip file was accepted?!

0

If you are on chinese version you cant install Global version, there is way to trick phone to think that it is global, i think that i found it on XDA

0

when i had firmware corrupt thing it was after i rooted the phone.
so i downloaded an update from this website and not via the update app and it worked.

Don't just think. DO!!!

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.