Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • H+ Data Connection not working


    Device is a rooted Meizu Pro 5 running 5.1.6G Firmware and root apps such as SuperSU, Xposed Framework and Flyme Tools

    Hi guys, hope I’m posting in the right section.

    So i recently got my Pro 5 and when my new sim card finally arrived i had some problems with my mobile network on my phone.
    First of all, I’ live in italy with an italian carrier [obviosly} which is PosteMobile and 2 GB mobile data per month.

    So when i first got the phone the H+ data connection worked for some time without problem but it stopped working shortly after and I got only 3G data connection at best.

    I’m not quite certain but it might have to do something with the fact that i rooted my device and maybe some root app is causing this problem. But the only thing that comes to mind which could be causing this problem would be Flyme tools but I can’t tell.

    Is there some hidden option that allows me to use H+, is it really a root issue or could it just be bad reception all along?

    Although I don’t think it is a reception problem because my mother has the same carrier with the same dataplan as me and can use it without problems. [She has a Galaxy Device].

    If you need more information just ask and help would be much appreciated :D.

  • I highly doubt that it has anything to with the rooting.

    Are you sure that you haven’t used up your 2GB data allowance?

    I don’t know how your data plan works but it is quite common that the data connection gets downgraded when you have used up your data allowance. It sounds to me that that is what you are experiencing.

    Meizu MX4, Meizu Pro 6

  • I also think it’s not related to root.
    Data limitation may be a cause. My thoughts are more about flyme tools. Don’t you enabled icons settings or others stuff that would replace h+ icons with another one? You can still temporarily disable it and check

    Meizu PRO 5 4Gb | ID changed, rooted & running latest G build (beta) + Xposed + TWRP

  • My data plan is fixed and I can check in the providers app that I have about 1GB left so it’s not that… I don’t think it’s a problem with the icon itself since browsing feels just slower than usual because even the google page needs about 8-10 seconds to load which shouldn’t be the case with H+. And sadly after disabeling Flyme Tools and even the Flyme notification fix tool it still didn’t change.

    It shouldn’t be a problem with my settings either because no matter if I choose to only “use 3G” or to “use 3G first” in the notification panel it should be using H+ in both cases since it is faster than 3G anyway.

    And of course if I enable “only use 4G” nothing works since I dont recieve 4G in my area.

    Is there no such setting to only use H+ or use it first or is that included in the “Only use 3G” and “Use 3G first” option?

  • HSPA+ is part of 3G the same way as EDGE is part of 2G. As far as I know then you cannot force the phone to only use the HSPA+ part of 3G.

    I guess you have tried at different times of the day (in case the network was heavily loaded) or at different locations in case you have been connected to a basestation that doesn’t support HSPA+ (not very likely though)?

    Meizu MX4, Meizu Pro 6

  • So the issue is fixed and i hate to admit that it was a stupid mistake. After checking the “About phone” section in the settings in the “Information about SIM” i could see that I actually was using HSPA+.

    The reason why H+ wasn’t showing is that I used the iPlus theme for the device which doesn’t include a H+ icon.

    The internet felt slow because it probably was a reception issue when I was testing it.

    Thank you very much for your help :D

Posts 6Views 622
Log in to reply

Looks like your connection to H+ Data Connection not working was lost, please wait while we try to reconnect.