Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

Replacing the firmware on Meizu M2

0

Hi to all!

I own a Meizu M2 phone bought in China with supposed international firmware but what finally I have in my hands has some Chinese software which I don’t like at all… Details of the firmware as taken from the phone are as follows:
Model number.M2
Android version 5.1
Build number.Flyme OS 84.5.3.2.A
Baseband MOLY.LR9.W1444.MD.LWTG.CMCC.MP.V10.P44,2015/08/24 10:51
Searching various posts I couldn’t locate such Flyme OS.
I want advise what is the recommended flyme international firmware, and how to update/upgrade so it can be used in Greece, without the said Chinese soft… which I tried to remove but I failed…
The phone seems to be good and it’s working fine.
Any advise will be much appreciated.
Thanks

Charilaos

0

@oldfox first of all welcome.

Here a few facts:

  1. Only an official overseas retailer sells the real Global/International device.
  2. This indicates someone messed arround with the installed firmware. I assume that the correct build number is somehwat around 4.5.3.2A.
  3. As you own a chinese device, you need to do a bypass to install the international/global firmware.

Therefore here the link for the guide:
https://forum.meizufans.eu/topic/2599/guide-how-to-install-i-international-firmware-on-your-chinese-mainland-meizu

Additionally I advise that you read this, so you have a basic idea how you usually install a firmware.

0

Geia sou file.
Who sold you this phone as international?
As you said, A firmware is the Chinese version.

0

Good evening to “Rey” and “Viper”!

Instructions of Rey noted with many thanks. I’ll give you details when everything is finished. In mean time, I downloaded the soft and tried to extract. the second time seems to be succeed…
I told a colleague to order with international specs and bring it to me, which he did, but apparently he is not familiar with the Chinese tricks… . (because of the restrictions of capital control…). As I have been working in China for more than 8 years I know many tricks of their business… Anyway what is done… finished. I try to bring it in order. Thanks

"

0

To "Rey"
Hi again.
When i tried to follow method 1 for replacing the software, using settings>accounts>My flyme>… there is not anything like personal settings… I log in to my account, still nothing like personal settings, so I can’t change the privileges… in fact, data and sync is open, phone finder is open but the flyme communications is NOT open because the SIM (Greek Vodafone) doesn’t support the service… So far, I’m blocked! I’ll try other methods, and let you know. Thanks again

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.