My MX5 suddenly jumps to an older OS, all data becomes inaccessible

Hi, I’ve faced a strange problem today. My MX5 has been working very well during 5 months using Flyme OS 5.1.2.0 G. Today, while I’ve been using Google Maps, the application dissapeared and instead I’ve got something looking like Flyme OS 4.5 - blueish screen, round icons - and with limited functionalities, like it doesn’t have fingerprints recognition, no sound control, cannot activate USB debugging. Strangely, “About the phone” shows that the OS is still the same - 5.1.2.0. All my data seems to be lost: no photos, no contacts, no calendar, no sms. Some Meizu applications like Security have gone as well.
I’ve tried to reboot several times and noticed a strange thing. The phone boots in “normal mode” - in 5.1.2.0, using my custom background, then the OS loads with my usual environment, I can see my apps, I can see contacts, photos etc. But just few seconds later - everything dissapears and the “ugly old OS” comes up blocking all my data. It looks like if it was an external application launched on startup after the others. A virus?
I can’t enter recovery mode pressing Volume+ and Power keys. Using Volume- and Power, I get “Fastboot=>” message but then nothing else happens.

Has anybody an idea about what is going on?
Thanks in advance for your help

Dimitri

last edited by samdimparis
Admin

@samdimparis this is one of the strangest cases I have ever seen.

So lets go step-by-step.

  1. Did you connected your phone to your PC to check whether or not the data is still there?
  2. Did you tried to perform a clean installation of the firmware (try doing it over the stock file explorer in your case)? It might has happened that you’ve got a virus or something else unwanted.
  3. Did you do anything else to the device?

About the problem to enter the recovery.
Shut the device down and wait a few seconds after the screen went black. Now press Volume Up first and then Power.
If this still doesn’t helps try to repeatedly press the Volume Up button while booting.

Hi Rey, thank you for your message. I’ll try to be as precise as I can.

Did you connected your phone to your PC to check whether or not the data is still there?

connecting the phone to my PC shows just few folders most of them empty. If say I take a photo, it appears in DCIM folder as it should. It looks like my files are inside an invisible partition to which I lost the access. BTW, I can see a grey “Other” block of data whose volume (>2Gb) corresponds to my lost data.
I am confident that my files are still there, because, as I said, the first few moments after boot I see my custom background and I even have the time to enter the gallery and see my photos are there. Then - click - everything disappears and I get the “ugly OS”.

Did you tried to perform a clean installation of the firmware

No, I didn’t. The “ugly OS” was kind enough to switch USB debugging off and no way to bring it back.

Did you do anything else to the device?

Nope. I’m searching now for tools allowing me to enter hidden folders on my phone from my PC.

About the problem to enter the recovery.

None of your methods work :(

last edited by samdimparis

Hi Samdimparis, I have the same issue as you when I run out of battery, I connected to charge and when I had a 6% of battery, my mobile runs normally just the first 5 seconds, then crashes and takes me to an old screen without my apps, photos, and all that. I can’t even find my contacts in my SIM card. I have exactly the same problem as you so I hope we will fix it early.

Hi vidal, in my case the battery was about 80%.
It looks like a backup mode with just basic functions. BTW, what happens if I block my phone (or erase my data) via Google?
Is it possible to do a kind of disk format?

Hi dimitri, the thing is that I don’t want to lose all my stuff by erasing all the mobile.
I think it’s possible to format all, by using the option in the mobile or doing a hard reset, but all your other stuff (the one that we see in grey in our storage bar) will be deleted permanently. I just want to keep it and then do the hard reset

@Rey I have the same problem, and also I can’t enter to the recovery mode or anything of this modes to reboot the sistem. So, basically, I have a mobile with two different OS in one and I can’t reset or format it. So strange.
Thank you, waiting your response
Vidal

@vidal11
Have you found anything? As for me - I didn’t. I’m ready to hard reset the device but don’t know how to do that given that USB debugging is off

Hi,i have the same problem but I can see my icons apps for fews second after system lauched…
I will try to upgrade to last versions without format data.

@samdimparis
Nope, I didn’t… This is making me more crazy every second… I tried to hard reset without te USB but it doesn’t work, and with the USB I can’t install any room or something like apk because it shows me a message like “App not Installed” or something like this so… I called MeizuSpain, and I have the garanty at least for a year so they will give me a new one, but it’s so strange this problem because we are the only ones… Hope you find a way to solve it !
I will check everyday this post only to understand how to fix this !

HI, update firmware not working, it’s just restart without any changes…
reset factory from setting menu is missing.
" volume + button and on " reset factory also not working
also Upon switching off the phone and then turning it on, there appears a toast at the bottom with a couple of Chinese characters followed by “unknown error from sdk”.

meizu mx5 Chinese with Flyme 5.1.5.0G

The same problem with me. Has someone found a solution?

hi,friends thank to precise the origin of your phones and the firmware version

Hi, mine is bought in France. Firmware 5.1.2.0 G
It worked perfectly for more than 5 months

try to root and then install clockworkmode recovery

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.