Meizu m2 Note Issue (Bricked)

Hello EVERYONE!

Some time ago a bought M2 note M571, OS 4.5.1.1i. From 1st day it it was giving “Firmware Corrupt” messege when i trued to update it, with any update…zip G,I,U, any of them was giving that error. So i tried to make it G, but now it’s bricked, bootloader is locked so i can’t install anithing custom, and for update.zip-s is it giving same error “Firmware Corrupt”.

Please help me with this issue!

Contributor

@i2bz Hello.
please add more details.

It sounds like your phone is a soft brick (so not really a brick). WHat did you do? Be detailed.

Why don’t you update + clear data to an “A” firmware?

last edited by Ultrametric

@Ultrametric Hello

That is the problem i tried to do this but none of firmwares are working. I tried all of them everytime it gives me error like “Firmware Corrupt”

Contributor

@i2bz You said that already.

But you still did not explain what you did :(

Contributor

@i2bz
As said before if you did this then you have a Soft-Brick and your solution is update + clear data. The End.

So summary:

Problem: Soft brick and recovery works

Solution: Update + Clear Data from Recovery.

Read the Wiki: https://wiki.meizufans.eu/index.php/Main_Page
And download an A firmware from here: http://www.flyme.cn/firmwarelist-10.html#3

Or direct link: Flyme 5.6.5.24 A beta
Stable direct link: Flyme 5.1.5.0A

last edited by Ultrametric

@Ultrametric

Thanks, i will try it now :)

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.