Can't go back on firmware and no Google Play Store

Hello, I have a Meizu MX4 Pro 32GB and have the latest firmware from 10 of may, still beta.

I want to go back to an internacional firmware so I can have Portuguese language but I’m not being able. All firmware files I try to flash are corrupted. Isso this normal?

I have first to download to PC and then copy the file to the root of the phone or downloading through phone browser is acceptable?

Tried the last option a lot but all the files are corrupted and the phone isn’t updated.

Another problem is with Google Play Services. I download Google Installer from Meizu appstore an run it. However the app seems to block all the time. Is there another way to contour this?

Thanks for your help. Really in need of it.

Admin

@jorgefcbastos do you even own an international device?
As it is a long time you were here the last time I do not remember quite sure.

Also which firmware are you trying to install (I assume 5.1.5.0G)?

About Google Play:

  1. Delete your account.
  2. Clear Play Store and Play Services data.
  3. Reboot.
  4. Login again.

I don’t know exactly the version but I already had internacional version firmware installed in this device.

About Google Play, I just installed Play Services, Google Play APK and Google Installer but no info was put in those apps. Google Play open and is shut down imediatly, Play Services the same.

One problem solved. With the new beta release i have been able to install Google Play.

Now, can I go back and install a new firmware?

0_1463490798220_S60517-141219.jpg

last edited by jorgefcbastos

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.