Meizu pro 5 have rooted rom but lost recovery - phone can boot pls help!

Hi

i was stupid enough to unlock my bootloader and flash recovery, then reflash back latest meizu stock via twrp , and flashing again the twrp recovery image,

i don’t why, but the first init of the rom update ****ed my recovery up and now i lost recovery (even the stock, the phone just booting to the rom)

fastboot oem unlock isn’t possible because i’m on locked bootloader rom.

i tried to flash the recovery via rashr with the backup i made and i can’t because of busybox, i guess it’s because the bootloader lock

is there any script or way that i can stock recovery back?

actually if lost the rom i lost my phone…

please help!

Meizu Pro 5

Meizu update contains both locked bootloader and stock recovery. So if you flash it directly it’s not surprising.
You can still redo the whole process : unlock the bootloader with leaked beta, flash twrp and then flash the rom you want. For the last step, be sure to edit the zip first and remove or replace the bootloader and recovery with the ones you want to keep

no i can’t, i can only flash system partition from the rom shell itself

rom can’t touch the recovery / boot / bootloader partitions

the only way is to do fastboot with the right token

or by some exploit, which doesn’t exist yet.

Meizu Pro 5

I don’t see why you can’t.
As soon as you can go fastboot, you can flash official recovery… You won’t be able to flash the twrp and that’s why you will need to follow the full process as described earlier…
The official recovery does have all the requirements (signature and so on) to be flashed with command-line while running locked bootloader

last edited by Kikounet95

Same here: I unlocked the bootloader and installed twrp. I was on 5.1.3.G and wanted to update to 5.6.5.10, but i forgot to delete the files bootloader and recovery from the update.zip… Now i cannot get into the recovery, but i can reach fastboot. in fastboot i tried to unlock the bl with the command “fastboot oem unlock”, and it seemed to be ok, but nothing happened, the bl kept unlocked… So for now i cant flash the update 5.6.1.19 (for unlocking BL) because i cant reach the recovery… If i push the volume up button + power on, the device will power on to the system… Anyone an idea what to do? My meizu pro 5 starts without problems to flyme… I know, i´m an idiot, believe me! If i try to flash the stock recovery with “fastboot flash recovery stock.img” i get an error “Failed: permission denied”

last edited by borisku
Meizu Pro 5

Guys. I did it also. So unless meizu changed something in never build it should work fine. Are you sure you are using the correct file to flash?

Could you please place a link to a correct file?

tried to do
fastboot flash recovery recovery.img
AKA AKA boot boot.img
AKA AKA bootloader bootloader
fastboot oem unlock not possible

i get permission denied on all the stock meizu files i tried,

the file is not even scanned , just all these partitions are locked

the only user way to flash recovery / boot / etc is by recovery

and when recovery doesn’t exists, you able to to do that by the platformtool with the correct tokens, and the latest version doesn’t fit the tokens of the platformtools that we have, or by dnw mode, which i think its kind of JTAG / UART or something

also , dd is not possible to these partitions, only system partition can be flashable by dd

Contributor

If you unlock the bootloader it stays until you overwrite it.

So if you flashed a full FlymeOS ROM including bootloader, you thereby locked your phone.

If your recovery is gone and the phone locked you can get a new main board.

Read the Ubuntu brick topic, try the tips, dunno if it helps you.

You must have loads of time so pretty please read through all of this topic.
Link https://forum.meizufans.eu/topic/3846/tutorial-meizu-mx4-android-unlock-unbrick/201?page=1

last edited by Ultrametric

We don’t replace board because of partition lock, its stupid, i will keep figure it out

last edited by Eliad Dadon
Contributor

@Eliad-Dadon is this your first Meizu? If so head to the Mx4 section and read up. You aren’t the first who intends to spent his free time on such a project.

A good amount of people ended up getting new main boards.

Anyway, your phone, your time, you know best what to do with both.

Read all of this: https://forum.meizufans.eu/topic/3846/tutorial-meizu-mx4-android-unlock-unbrick/201?page=1

last edited by Ultrametric

Guys can`t we use the oposite of this to unlock bootloader ???

===========================================================
| Trace On

[09:42:58:894]Tips: Device insert. ID: 06f64ec71788
[09:42:59:408]Token sign operator. Begin -----------------------------
[09:42:59:410]Tips: Token signing…
[09:42:59:410]Read uboot serial. Command: fastboot -s “06f64ec71788” oem random
[09:42:59:506]…
(bootloader) 910DB9F36F3E74AA5C37C87238E6AC39
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:09:975]8377A57635B2BF9BFB74D5B1AD43E19E08C325F86E209C4959ECE4A08122BF41D9CA5AA0DDCA34FAADFB839858A5375CAA612D20200E0853B258FEF871C3F13C72B502EDF7F8B8B2C315A049B1F72CEDB6021DB7B01C2E01F69B2558D4F1F9A21E0CA3631AC6466488820DA970B2B63BA5EA2D1B537FB71B6F65ACD82179CAD40BEDE62E16EC68A993ABA70EBF14BAF68D71D773107526A3EE176B0184B42A1F7AA823C59DB79A6249324B60FA6B4E073C7E08DFF484D70A2EAFFD5EE84DB8FDC104E217E7E9E3E42F329130F26B965D5A88513E7E6F87A1D5A5ED1B2B055D1866E4DE1686EA13928DDCAA848B6C30319E81B4B8D429B19CED489E33AB893838

[09:43:09:975]fastboot -s “06f64ec71788” oem verify:8377A57635B2BF9BFB74D5B1AD43E19E
[09:43:10:072]…
(bootloader) 16
OKAY [ -0.000s]
finished. total time: -0.000s

[09:43:10:072]fastboot -s “06f64ec71788” oem verify:08C325F86E209C4959ECE4A08122BF41
[09:43:10:168]…
(bootloader) 32
OKAY [ -0.000s]
finished. total time: -0.000s

[09:43:10:168]fastboot -s “06f64ec71788” oem verify:D9CA5AA0DDCA34FAADFB839858A5375C
[09:43:10:263]…
(bootloader) 48
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:10:263]fastboot -s “06f64ec71788” oem verify:AA612D20200E0853B258FEF871C3F13C
[09:43:10:359]…
(bootloader) 64
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:10:359]fastboot -s “06f64ec71788” oem verify:72B502EDF7F8B8B2C315A049B1F72CED
[09:43:10:454]…
(bootloader) 80
OKAY [ -0.000s]
finished. total time: -0.000s

[09:43:10:454]fastboot -s “06f64ec71788” oem verify:B6021DB7B01C2E01F69B2558D4F1F9A2
[09:43:10:550]…
(bootloader) 96
OKAY [ 0.000s]
finished. total time: 0.000s

[09:43:10:550]fastboot -s “06f64ec71788” oem verify:1E0CA3631AC6466488820DA970B2B63B
[09:43:10:645]…
(bootloader) 112
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:10:645]fastboot -s “06f64ec71788” oem verify:A5EA2D1B537FB71B6F65ACD82179CAD4
[09:43:10:740]…
(bootloader) 128
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:10:740]fastboot -s “06f64ec71788” oem verify:0BEDE62E16EC68A993ABA70EBF14BAF6
[09:43:10:835]…
(bootloader) 144
OKAY [ 0.000s]
finished. total time: 0.000s

[09:43:10:835]fastboot -s “06f64ec71788” oem verify:8D71D773107526A3EE176B0184B42A1F
[09:43:10:930]…
(bootloader) 160
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:10:930]fastboot -s “06f64ec71788” oem verify:7AA823C59DB79A6249324B60FA6B4E07
[09:43:11:025]…
(bootloader) 176
OKAY [ -0.000s]
finished. total time: -0.000s

[09:43:11:025]fastboot -s “06f64ec71788” oem verify:3C7E08DFF484D70A2EAFFD5EE84DB8FD
[09:43:11:120]…
(bootloader) 192
OKAY [ -0.000s]
finished. total time: -0.000s

[09:43:11:120]fastboot -s “06f64ec71788” oem verify:C104E217E7E9E3E42F329130F26B965D
[09:43:11:215]…
(bootloader) 208
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:11:215]fastboot -s “06f64ec71788” oem verify:5A88513E7E6F87A1D5A5ED1B2B055D18
[09:43:11:310]…
(bootloader) 224
OKAY [ 0.000s]
finished. total time: 0.000s

[09:43:11:310]fastboot -s “06f64ec71788” oem verify:66E4DE1686EA13928DDCAA848B6C3031
[09:43:11:405]…
(bootloader) 240
OKAY [ 0.001s]
finished. total time: 0.001s

[09:43:11:405]fastboot -s “06f64ec71788” oem verify:9E81B4B8D429B19CED489E33AB893838
[09:43:11:595]…
(bootloader) 256
(bootloader) verify success
OKAY [ 0.129s]
finished. total time: 0.129s

[09:43:11:599]Tips: Token singed successfully
[09:43:11:599]Token sign operator. End -----------------------------
[09:43:11:601]Tips: Format part
[09:43:11:601]fastboot -s “06f64ec71788” oem cmd “scsi erase 0 0x80000 0”
[09:43:15:879]…
OKAY [ 4.177s]
finished. total time: 4.177s

[09:43:15:881]Tips: Format part. ok
[09:43:15:888]Tips: Partition disk
[09:43:15:888]fastboot -s “06f64ec71788” oem cmd “fdisk -c 0”
[09:43:16:080]…
OKAY [ 0.132s]
finished. total time: 0.132s

[09:43:16:082]Tips: Partition disk. ok
[09:43:16:082]Lock device. Command: fastboot -s “06f64ec71788” oem lock
[09:43:16:178]…
OKAY [ 0.004s]
finished. total time: 0.004s

[09:43:16:178]Read lock state. Command: fastboot -s “06f64ec71788” getvar lock_state
[09:43:16:370]lock_state: locked
finished. total time: 0.049s

[09:43:16:370]Fastboot download. Begin -----------------------------
[09:43:16:370]Command total£º9
[09:43:16:371]Tips: bootloader running …
[09:43:16:371]fastboot -s “06f64ec71788” flash bootloader “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\bootloader”
[09:43:16:561]sending ‘bootloader’ (1290 KB)…
OKAY [ 0.056s]
writing ‘bootloader’…
OKAY [ 0.019s]
finished. total time: 0.075s

[09:43:16:563]Tips: bootloader successfully
[09:43:17:065]Tips: ldfw running …
[09:43:17:065]fastboot -s “06f64ec71788” flash ldfw “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\ldfw”
[09:43:17:257]sending ‘ldfw’ (1028 KB)…
OKAY [ 0.030s]
writing ‘ldfw’…
OKAY [ 0.017s]
finished. total time: 0.047s

[09:43:17:259]Tips: ldfw successfully
[09:43:17:762]Tips: dtb running …
[09:43:17:762]fastboot -s “06f64ec71788” flash dtb “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\dtb”
[09:43:17:859]sending ‘dtb’ (140 KB)…
OKAY [ 0.011s]
writing ‘dtb’…
OKAY [ 0.006s]
finished. total time: 0.017s

[09:43:17:861]Tips: dtb successfully
[09:43:18:367]Tips: bootimg running …
[09:43:18:367]fastboot -s “06f64ec71788” flash bootimg “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\boot.img”
[09:43:19:223]sending ‘bootimg’ (15848 KB)…
OKAY [ 0.349s]
writing ‘bootimg’…
OKAY [ 0.223s]
finished. total time: 0.572s

[09:43:19:224]Tips: bootimg successfully
[09:43:19:726]Tips: bootlogo running …
[09:43:19:727]fastboot -s “06f64ec71788” flash bootlogo “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\logo.bin”
[09:43:21:058]sending ‘bootlogo’ (24301 KB)…
OKAY [ 0.570s]
writing ‘bootlogo’…
OKAY [ 0.353s]
finished. total time: 0.923s

[09:43:21:060]Tips: bootlogo successfully
[09:43:21:562]Tips: recovery running …
[09:43:21:562]fastboot -s “06f64ec71788” flash recovery “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\recovery.img”
[09:43:22:323]sending ‘recovery’ (16032 KB)…
OKAY [ 0.352s]
writing ‘recovery’…
OKAY [ 0.179s]
finished. total time: 0.531s

[09:43:22:324]Tips: recovery successfully
[09:43:22:829]Tips: system running …
[09:43:22:829]fastboot -s “06f64ec71788” flash system “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\system.img”
[09:44:22:118]sending ‘system’ (1139308 KB)…
OKAY [ 25.124s]
writing ‘system’…
OKAY [ 29.681s]
finished. total time: 54.805s

[09:44:22:122]Tips: system successfully
[09:44:22:624]Tips: custom running …
[09:44:22:624]fastboot -s “06f64ec71788” flash custom “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\custom.img”
[09:44:30:804]sending ‘custom’ (174280 KB)…
OKAY [ 3.861s]
writing ‘custom’…
OKAY [ 2.489s]
finished. total time: 6.350s

[09:44:30:809]Tips: custom successfully
[09:44:31:312]Tips: proinfo running …
[09:44:31:312]fastboot -s “06f64ec71788” flash proinfo “D:\M86\ÊÔ²ú¹Ì¼þ\20150929051338_prd_stable\proinfo”
[09:44:31:408]sending ‘proinfo’ (1 KB)…
OKAY [ 0.008s]
writing ‘proinfo’…
OKAY [ 0.005s]
finished. total time: 0.013s

[09:44:31:409]Tips: proinfo successfully
[09:44:31:909]Fastboot download. End -----------------------------
[09:44:31:911]Tips: Poweroff
[09:44:31:911]Poweroff. Command: fastboot -s “06f64ec71788” oem poweroff
[09:44:32:008]…
OKAY [ -0.000s]
finished. total time: -0.000s

[09:44:32:012]Tips: Poweroff. ok
[09:44:32:272]Tips: Elapsed time: 63.3s. PSN: 86064B0002D4

last edited by 2uk

[09:43:16:082]Tips: Partition disk. ok
[09:43:16:082]Lock device. Command: fastboot -s “06f64ec71788” oem lock
[09:43:16:178]…
OKAY [ 0.004s]
finished. total time: 0.004s

[09:43:16:178]Read lock state. Command: fastboot -s “06f64ec71788” getvar lock_state
[09:43:16:370]lock_state: locked
finished. total time: 0.049s

Hi 2uk ,

Where is the trace from? Did you successed?
I cant see screenshot,

Ok its from the MultiPlatform Log

As i said the program asks for random key and then generates token,

The problem is that the current version of the multiplatform program doesn’t know the generation formula for the new bootloader that we.are.on…

But according to the logs , maybe its a good point to start

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.