Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • [FULL HOW TO] Meizu M2 Mini | Root, adb, unlock bootloader, TWRP recovery and CM 12.1


    alt text

    Intro
    Just a simple HOW TO to centralize everything I found on Russian, Italian, xda and these forums.
    M2 Mini has good hardware but very poor software, going to CM is a relief !

    Disclaimer
    I’m not responsible for bricked device.
    You may loose warranty.
    You need basic knowledge of using adb tools and rooting phones.

    Boot in Recovery and Fastboot
    Boot in recovery : power on holding Volume Up and Power
    Boot in fastboot mode : power on holding Volume Down and Power

    Rooting
    King Root works well http://www.kingroot.net

    ADB Drivers
    Google drivers won’t recognize M2 Mini, you have to edit the inf file.
    You have to activate USB Debugging in the Developer Options for ADB to work.

    1. Download drivers at: http://developer.android.com/sdk/win-usb.html

    2. Edit android_winusb.inf

    3. Go to [Google.NTamd64] section and add this to the end of the section :
      ;MEIZU M2
      %CompositeAdbInterface% = USB_Install, USB\VID_0E8D&PID_201D&MI_01
      %CompositeAdbInterface% = USB_Install, USB\VID_2A45&PID_0C02&MI_01

    4. Reboot Windows without driver signature enforcement
      HOW TO: http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

    5. Install modified driver
      HOW TO : http://developer.android.com/tools/extras/oem-usb.html

    Unlock bootloader
    You have to be on Flyme OS 4.5.4i for bootloader unlocking to work.
    DOWNLOAD LINK : https://forum.meizufans.eu/topic/3905/flyme-os-4-5-4-stable-m2

    1. You need busybox on the phone
      DOWNLOAD LINK : https://play.google.com/store/apps/details?id=stericson.busybox&hl=en

    2. You have to download the unlock_bootloader.sh
      DOWNLOAD LINK: http://www37.zippyshare.com/v/fvm5edpr/file.html

    3. Copy file to sdcard via MTP or ADB
      adb push unlock_bootloader.sh /sdcard

    4. Execute the file as root from ADB
      adb shell
      su
      (accept warning on the phone)
      sh /sdcard/unlock_bootloader.sh

    5. Unlock
      adb reboot bootloader
      fastboot oem unlock
      (wait for the phone to display confirmation)
      “Volume Up” to accept
      (wait for unlocking)

    6. Reboot your phone into Flyme OS
      It is very important to restart your phone and wait for Flyme OS to boot up completely before flashing a custom recovery.

    Custom recovery (TWRP)
    If you didn’t boot into Flyme OS at the previous step, you might be stuck in boot loop in recovery and need to go back to the stock recovery (Uploaded on XDA by @murtaza1326)
    DOWNLOAD LINK: https://drive.google.com/file/d/0B6kCPdWyvl3xa1RDWVRDRHlfS2c/view
    XDA LINK: http://forum.xda-developers.com/showpost.php?p=66476298&postcount=574

    1. Download last TWRP 3
      DOWNLOAD LINK: https://mega.nz/#!PVcihSST!0yHN3p6dsKqAgW2-2krUSvvzRA-bFQmPR16wUbC7aKs
      FOUND ON: http://www.movilesdualsim.com/tema/twrp-3-0-2_modnat-ltt-multilanguage.132746/

    2. Flash recovery
      fastboot flash recovery_3.0.0.3NAT&LTT.img

    CyanogenMod 12.1
    Last version seems to be 0.9 from April,16th 2016 on Russian forums.

    1. Download Cyanogen
      FORUM LINK: http://4pda.ru/forum/index.php?showtopic=715935
      DOWNLOAD LINK: https://drive.google.com/file/d/0Bwzrxcf3P6N6S1hzaUYtNGFwMDA/view

    2. Download Google Apps
      GITHUB LINK: https://github.com/AlexLartsev19/cgapps/releases
      DOWNLOAD LINK: https://github.com/AlexLartsev19/cgapps/releases/download/20160423/cgapps-arm-5.1.1-201604241754.zip

    3. Boot into recovery
      Hold “Volume Up” and Power

    4. Copy everything to sdcard via MTP

    5. Full wipe
      Go to Wipe > Advanced wipe > check Dalvik, System, Cache, Data > Wipe

    6. Flash CM and Gapps
      Go to Install, select your CM zip file and install.
      Do the same with Gapps.

    7. Restart your phone

    Enjoy !

  • @madcorp Thanks for this tutorial, U did wery good and make it easy for all, of us.
    I have only one question…
    How is the procedure for reverting from Cm to Flyme?

  • I’ve not tried it.

    The secure way must be :

    1. Flash stock recovery in fastboot mode.
    2. Download any FlyMe OS zip file and put it in the root of your internal storage
    3. Boot in stock recovery and apply update

    Maybe you can install FlyMe directly from TWRP, you’d have to try :)

  • Hi, I have a problem with fastboot driver. When I reboot in fastboot mode, in devices manager there is an unknow android device. I try to manually upgrade driver from your guide without lucky…any help?

  • I’ve solved fastboot issue but I have soft bricked my device. After unlocking procedure ok, I have pressed power button for turn off device and reboot it. After my meizu go in bootloop mode (little vibration, meizu logo and reboot…in loop) I entered after in stock recovery mode and I put 4.5.4I in a recovery partition and start flash…I hope it work…any suggestions? Thanks

  • fiuuuuuu…devis boot…Lord…panic…I assume that I lost unlock right?

  • @pedjakis from twrp you can update/downgrade your firmware version. But recovery will stay twrp

  • @madcorp okay. I unlocked my device bootloader without modifying google drivers. Installed official google drivers and manually installed through device manager. Works like a charm! Annd your way of pushing unlock bootloader file is correct but to install that file there is some annoyance. You should get an error that your file doesn’t exist. Your problem is not corrext path to a file.after you unlocked bootloader you Can get a BRICK if you do not install update.zip at flyme recovery! If you succesfully done all thing you will get that there is no update.zip. Please @madcorp add a disclaimer

  • If you succesfully unlocked bootloader and have twrp recovery do not revert to stock recovery because you will loose our precious super su. Before unlocking go and get root from flyme acc and install supersu from google play store and busybox. Supersu works after upgrading to any flyme version. For example now i am using 5.6.4.19 latest yun os based with supersu not kingroot.

  • Annd cm12.1 full of holes on meizu. Before meizu m2 i used NEXUS 4 so i was flashaholic, tested a lot custom ROMS but this cm for meizu m2 Its beta release and there are a lot bugs that i don’t like much. I registerred them on russian github but its not solvable. Doesnt work all sensors! Audio is less louder, Ui performace is slow. Home button has very long delay for operation execution. Have a bug of black screen on call. Compass doesnt work. Battery draining much faster than flyme 5. So a lot problems, be good topic owner and add a disclaimer and for cm12.1. Seems that its early to be happy that we have cm12.1.

  • I try to explain what I made…sorry for my english :)

    1- adb shell,su, sh /sdcard/unlock_bootloader.sh: SUCCESS;

    2- adb reboot bootloader, fastboot oem unlock: SUCCESS;

    ok?

    After this I turned off my phone ok? When I turned on, I haved ugly boot loop (little vibration, meizu logo IN LOOP).

    Luckily, from this state, I am able to enter into STOCK recovery.

    At this poit, I have connected phone at pc…and luckily I have seen a partition called “D: Recovery”.

    I putted in this partition stock uptade.zip of flyme os 4.5.4I and I flashed it…

    Now my bootloader is open or not?

  • @autoradio78 bootloader never locks after you flash a file. Your problem why you got bootloop that you turned off and turned on. You need to turn off and turn on to recovery mode. Press on start and wait for result, reboot. This solves bootloop issue. Dont know how but solves

  • Ok so I assume that my bootloader still unlocked…but according your test…knowing that mediatek does not release the source…verily, I passed the desire to try this cm…

  • When i am running the “adb reboot bootloader” command i am getting device not found error? Is pc is mandatory to unlock the boot loader?

    Respect Others…

  • @TeckFreak yep. It seems like you didn’t installed the drivers properly.

    Meizufans on Facebook
    Meizufans on Twitter
    Meizufans on Google+
    READ THE WIKI FIRST!!!

Posts 51Views 38066
Log in to reply

Looks like your connection to [FULL HOW TO] Meizu M2 Mini | Root was lost, please wait while we try to reconnect.