Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

M2 Mini, Stuck on upgrade to International or global on Chinese with 4.5.4U OS.

0

Miezu M2 Mini OS 4.5.4U, I am stuck! cannot upgrade from Chinese version. I have tried method 1 of the guide ‘How to install International firmware on Chinese-mainland Meizu’, but although System Privileges shows ‘Open’ trying the ‘su’ command in the terminal does not work. Tried several diff terminal emulators, some say ‘su’ command not available. Any help/ideas welcome please.

0

@mike_essex try using the A firmware. However, before you do that - did you rooted the device over the Settings? If not this is your issue.

0

@mike_essex please reflash through original recovery 4.5.3.2a with marked clear data. After that go to your meizu acc through mobile and gain root privilegues. Then use method 1 for converting your phone id from chinese market to european. This should work

0

Hi mgeranimus, Thanks for your advice. I was able to replace 4.5.4U with 4.5.3.2A as you suggested, but on a reboot the phone automatically upgraded the OS to 5.1.5.0Y without my permission/agreement.
Although there is no rooting provided, I used Kingroot to root and a terminal shell does work. Now I need to check to see if I can replace OS 5.1.5.0Y with an International version. Running the relevant chid.sh does change the ID, but not replace the OS. Not sure if I have the 4.5.4.2I update.zip in the right location…

0

Hi megeranimas. Following on from my earlier post, I have now succeeded in installing 4.5.4I, the international software. Had to reinstall 4.5.3.2A over 5.1.5.0Y, then reboot to install 4.5.4.I global. I am now very happy. Thanks to all those who post guides and helpful comments.

Log in to reply

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.