Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ Reload ]

Fingerprint and Back-Button stopped working?!

Hi guys!
I got my Pro 5 on December 2015, and now, a few months later the mTrack-Button isn´t working anymore. I don´t know why, because I did nothing to the phone, it occured randomly and i could not fix it until now. The thing is: The touchbutton for going back isn´t working anymore, same as the fingerprint sensor. Physicle press is working, so going back to the homescreen isn´t a problem. In the meantime I did all the stuff with the software-based ‘SmartTouch’.

What I tried till now:

  • Factory reset
  • Flashed newest chinese firmware & back to international 5.1.3.0g
  • cleared via recovery
  • tried everything I could imagine in the phone´s settings

What really confused me is that when i go to fingerprint & security settings and on to fingerprint management there is just ONE fingerprint captured, but i can not delete that one! I also can´t add new fingerprints…

I´m really disappointed of the phone right know, would have been better to buy another phone with better quality!?!

If anyone can help me that would be great!

Thanks :)

last edited by Michael Dürager

@Michael-Dürager You have performed a factory reset but the captured fingerprint is still there?

Yes, factory reset via Fastboot, than installed newest firmware. Still the same disfunction, Fingerprint 1 displayed in settings… but mTrack and “back” are not working…

My guess is that there is something wrong deeper in the system, maybe… I don´t think that there is a hardware issue, since the physical press is working in a normal way…

I can´t make it out… Normally I am very experienced in such things but the Pro 5 takes me to my limits… :(

Does noone other have or had this problem? Am I the only one who is threatened by this issue?

greetings,
Michael

last edited by Michael Dürager

@Michael-Dürager Okay, what you are going to do is to:

  1. Backup everything, apps, photos, videos, documents etc
  2. Install 5.1.3.0G (If you already have install it get a new copy and reinstall it), Check the option “Wipe data and cache”
  3. Go to Settings -> About the Phone -> Storage -> Factory data reset -> Check both of the options (this will erase ALL the data of the phone)
  4. Reboot the phone and once everything is configure look if everything is working

If that doesn’t solve the problem you should follow a fifth step that would be:

  1. Keep a previous version of the global firmware and install it (after you have done all the previous steps)

Hi everyone, my friend who has mx5 has same problem. It has just happened. I thought that was a hardware problem so we bought fingerprint button on aliexpress. Its about 10 $. I ll write when i get it.

@algebram Fingerprint for 10$
Is that cheap?

@algebram Did the new button work?
I’m having the same problem here with MX5, Flyme 5.1.6.0G .
The fingerprint sensor just stopped working (both as a back button and unlocking the screen)

hi everyone, i tried replacing new button, pressing works but touching or finger print didnt work.

Wow… So it’s not a hardware problem?!
I’m lucky I still have warranty. Soon I’ll send it to be fixed and I’ll update what happens.
Anyway this phone turns to be full of bugs and I’m thinking to switch to something else. It’s a total disappointment

Hi guys
I sent my phone to the store I bought it from for a fix, and I just received it back. They fixed it.
They just replaced the button.
To clarify, I had the home click working but the ‘fingerprint’ and ‘back’ weren’t working. They replaced the whole button and now everything is working.
They didn’t do any system restore or upgrade and they did not wipe any data. Just replaced the button.

last edited by Alaa Masalha

Have the same problem. Just bought PRO 5 with 5.1.6.0g. Shipped from China.

Interesting that few first hours touch and fingerprint didn’t work.
After one reboot or something I don’t know what it began work!

But after 2 days problem returned… and still here.

Hey guys same problem for me on my mx5… I have buy 2 button and 2 motherboard flat (1 was faulty) , at the end was flat cable…
It takes me 4 month (1 month each ship) to get a workly mback function.
Sorry for my bad English

Looks like your connection to Fingerprint and Back-Button stopped working?! was lost, please wait while we try to reconnect.