Flyme 5 _asking to enable wifi

Hi everyone,
In the latest Flyme 5 build for the M2 (5.1.4.0) I’ve noticed a little annoying thing, and I hope someone can help me sort it out.
If I use Tasker (or any different phone automation app) and I set it to turn on wifi when I reach a destination, upon reaching the destination the phone gives me a 20-second pop-up dialog asking me to allow for the wifi to turn on, otherwise it will stay off. So, I have 20 seconds to unlock the phone and confirm ‘yes, I want the app to turn wifi on’, otherwise wifi is not turned on.
This is very annoying because automation apps are supposed to, obviously, automate your phone, and this little nag is asking for a confirmation for something that even Google doesn’t block, and that is turning wifi on/off by third party apps.
Anyone have a solution or a fix?
Thanks

Admin

@krsmans you can change this behaviour in the Security Center. Simply go to Permissions>Privacy>Turn WiFi on.

@Rey said:

@krsmans you can change this behaviour in the Security Center. Simply go to Permissions>Privacy>Turn WiFi on.

I don’t have such an option in Security Center. There are a lot of other options (such as Send SMS, Write contacts, and 15 similar), but Turn WiFi on is not there.
Thanks for trying. Any other idea? Or perhaps someone else?

Admin

Actually it should be only 2 selections below Send SMS. Can you share a screenshot maybe?

@Rey said:

Actually it should be only 2 selections below Send SMS. Can you share a screenshot maybe?

Sure. Here’s a screenshot, but I don’t see it…!
0_1459789242256_S60404-165015.jpg

Admin

Thats very strange. Maybe try to use the test firmware (new release is planned for tomorrow).

@Rey said:

Thats very strange. Maybe try to use the test firmware (new release is planned for tomorrow).

Yes, it is strange. I’d be happy with an option in the dialog that would allow the system to remember my choice when I choose to allow an app to turn on wifi, but such an option is not provided.

Anyway, if I try the today’s test firmware I’d have to do it with Clear Data?
It might be silly to install and set up all my applications again just for this annoying issue.
Anyway, thank you for the interest in this topic.

Admin

You could go with a dirty flash.

P.S.: No release so far. Maybe they postponed it due to the launch event tomorrow.

@Rey said:

You could go with a dirty flash.

P.S.: No release so far. Maybe they postponed it due to the launch event tomorrow.

@Rey Could you please attach/send me a screenshot of the Turn on WiFi option (Sec. Center > Permissions > Privacy) from your phone (Pro 5, I guess)?
I’m currently in contact with meizu support service, and they seem very willing to sort this out.
Thanks

last edited by krsmans
Admin

@krsmans they cannot sort it out, trust me. They cannot even get Flyme working properly.
Pro 5

It is “WLAN einschalten”.
By the way, did you tried to go over Security Center>Permissions>App-Management? Maybe the option will appear there.

@Rey said:

@krsmans they cannot sort it out, trust me. They cannot even get Flyme working properly.
It is “WLAN einschalten”.
By the way, did you tried to go over Security Center>Permissions>App-Management? Maybe the option will appear there.

Thanks, man. Yes, I did try in App Management, but it’s not there. In fact, I can’t find a single place where this permission is required.
Anyway, I agree that Meizu’s history of fixing things is not the best, but yesterday they were very interested in this issue, we exchanged several emails trying to figure out what happened.
They claimed that the only place for the ‘Turn WiFi on’ option is under ‘Sec.Center > Data > WLAN permission’, but I proved them that this setting is only to allow apps to USE wifi, not to allow them to TURN ON wifi.
So then they became more interested and asked for a screenshop of the option in a different phone, so this is why I asked you.
They acknowledged that the issue is firmware-related, so I’m hoping for a fix in a future stable release. :)

Admin

@krsmans new release came out today, but it is a test firmware.
If you need a fix so bad, see what people report back about the firmware. If it is good, you could go for it.

last edited by Rey

@Rey said:

@krsmans new release came out today, but it is a test firmware.
If you need a fix so bad, see what people report back about the firmware. If it is good, you could go for it.

Thanks for the info, it’s very appreciated.
Yeah, I’ll try to catch some feedback on the firmware, especially since the change log says something about application permissions (although it’s unclear what exactly).
But I’d definitely go for a dirty flash, I really can’t stand installing and setting up everything back again, each time. :)

In any case, I haven’t heard back from the Meizu customer support since yesterday, so I have no idea whether they’ve implemented a fix or not. Honestly, I don’t think they had enough time even if they wanted to fix it.

@Rey said:

@krsmans they cannot sort it out, trust me. They cannot even get Flyme working properly.
It is “WLAN einschalten”.

@Rey Hi, sorry to ask you something like this again, but can you please send me (or attach) a screenshot of your phone’s Settings>About phone? Of course, hide any info from it that you perhaps don’t want publicly available.
The thing is - the guys from the Meizu Customer Center have taken a serious interest in this issue, they’ve even apologized for not fixing it sooner, but their engineers need to take a look at the About phone section in order to match it with the previous screenshot, and that would allow them to finally fix it.
I can forward you their emails if you wish.

Admin

@krsmans it is a Pro 5 running Flyme 5.1.4.0A:

Their emails are nonsense and don’t help a lot. They fix bugs only, if the chinese community reports them (not even then sometimes).

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.