Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript!

  • i want to install international fylme rom plz hlp me.. !!!


    currntly am using flyme os 4.5.4y (powered by yunos )
    facebook and massanger doesn’t work on tht rom
    i want to pun international rom. someone plz hlp me.

  • @m5zalm Hi. Remember to back up your data and download it from here.
    http://www.flymeos.com/firmwarelist?modelId=18&type=1 official meizu firmware, stable.

    Flyme OS 4.5.4I (international/global)

Posts 2Views 489
Log in to reply

Looks like your connection to i want to install international fylme rom plz hlp me.. !!! was lost, please wait while we try to reconnect.