How to install Viper4android on flyme 5

Hi everyone.
I recently upgraded my MX4 to flyme 5 and tried to install viper4android.
It led to a loop of installing drivers; this is due to selinux being set to ‘enforcing’ (I think).
The solution I used is from this page
http://androiding.how/how-to-fix-viper4android-selinux-policy-issues-on-lollipop/
You have to download the zip file and manually copy the ‘su.d’ folder to /system/
then follow the instructions.
Worked for me anyway

@djbrie Meizu pro5 owner here. Didn’t work for me. You got my hopes up with that title! haha

Ah, really sorry mate :disappointed:
Worked for me.
It sounded like the same problem of driver install loop that the pro 5 has
Are you using supersu for root?

I also installed busybox to ‘bin’ not 'xbin’
Not sure if that matters, but might be worth a try

Contributor

@djbrie you can’t help him!

The MX4 Pro and Pro 5 have a completely “un-normal” driver configuration.

@Ultrametric
Fair enough, I shall cease and desist :cop:

Nothing will get v4a to work for us with the PRO5 it seems. You’re lucky.

Meizu MX4 Pro

@Ultrametric why actually do these two phones have problems with v4a drivers? do you know a soloution?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.