Android OS Wakelock HELP!

I have had my m2 for about a month now and I used to get nice battery life about 6-7 hour screen on time. A few days ago I realized that in my battery stats the android os had surpassed the screen in battery usage. It had the phone awake almost all the time I had the screen off. Please help.

last edited by 4bdu1

Try install doze and purify

Experienced same thing. If you search the web, you will encounter that Flyme produced a lot of wakelock (namely EINT, PowerManagerService, WLAN AHB ISR). Some claimed it happen to be Mediatek bug, some said it is Wifi bug, some said it’s google location WiFi setting (always scan option is checked). I’ve tried so many thing, but it is still has a lot of wakelock.
I’m currently using BetterBatteryStats’ watchdog feature to notify me when phone is unable to go to deep sleep (my setting is if phone awake more than 30% when screen went off more than 10 mins, it will notify). Then, I restarted the phone whenever Flyme when crazy with the wakelock. It’s my workaround for now.
Hopefully, whatever Marshmallow Flyme update will resolve this issue.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.