[SOLVED] Root problem with Titanium Backup

Hello,
I have a problem with root priviledges on my MX5 with 4.5.4.1 I firmware version.

When I open Titanium Backup it says it has no root permits. I have opened root permissions in Flyme account settings and also use KingRoot with Purify and over there everything is all right.

Would be grateful for any help with this issue…

last edited by Slavedriver
Admin

Maybe try installing SuperSU from Chainfire (just the app, it then will help you to install the binaries).

Hello Rey, thanks for your tip. Unfortunately cannot install SuperSu it says that Installation is failed…

Edit:
I have uninstalled KingRoot and installed the most recent version from XDA which is 4.8 at the moment. Rerooted the phone via KingRoot again and now Titanium Backup is working fine. It seems there’s some problem with Flyme Account root for me. While I had rooted over there only the app was not working, neither SuperSu. I guess that the newest KingRoot also installed most recent SU binary.

Thank’s for help anyway☺

last edited by Slavedriver
Contributor

@Slavedriver If you use SuperSu 2.46 from the play store (and don’t update it.). The binaries build without a problem.

I tried to use 2.46 supersu but it doesn’t work. everytime it says that it fails to install the binary. Even if I have rooted via flyme account or king root. 😕

Contributor

@Slavedriver I am not fully sure but I have read that kingroot and supersu are no friends. They block each other.

Sometimes it helps to reinstall from the SuperSu settings.

@Ultrametric indeed. At least it seems so in my case. I guess I have 2 problems at one time:

  • root from Flyme account not working properly, so I couldn’t just use SuperSu,
  • KingRoot and SuperSu not working together.

Anyway at the moment I use KingRoot 4.8 with a success and Titanium Backup works fine.
Besides that I’ve found an app called Super-Sume which replaces KingRoot with SuperSu.
Maybe I’ll try that later.

Thank you for your assistance. 😀

last edited by Slavedriver
Contributor

@Slavedriver I have the MX5 and root every firmware so far.

I did not use 5.6.2.1 until today, will just install it. But 5.1.3.0G is easy to root and SuperSU works… so the 5.6.2.1 will work for sure.

But so far it worked on every single firmware… and all I did was:
-root the phone through Flyme Account
-reboot
-install SuperSU 2.46 + build binary normal
-reboot (after successful build)
-lock SuperSU to the RAM and allow auto access

… sometimes if SuperSU doesn’t auto start and I have to start it myself.

But that’s about it.

last edited by Ultrametric

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.