About earphones and Wi-FI

Hi guys, just bought an M2, as it’s my first smartphone ever (I only recently discarded my still working Nokia n78) I’d like to ask two things:

  1. Is it normal that no icon appears when i plug in my earphones? Other smartphones have it, i’m not quite sure if it’s a bug or if it’s just like this.

2)The Wi-Fi signal is damn weak! Am I the only one to have this problem? I measured it with an app, using for comparison my sister’s S4 and my other sister’s chinese 100€ smartphone, and they got at least -60/-70 dBm, where my M2 only got -80/-90. Could it be a software problem? I would prefer not to send it back to china and wait 3 months for it to come back.

BTW, i upgraded to the 4.5.4.2A version.
Thank you in advance for the help.

last edited by thenokiottos

@thenokiottos this is in software … Flash other rom i think that will work good.

Meizu MX4

I have the same wifi problem with my Mx4 and I think it’s an hardware problem because I already tried to change firmware and it’s the same

@xSurox
Really? Then how come nobody mentioned this in any review?

Changed to firmware 4.5.4 international but still have weak wi-fi.

I mean custom roms like elephone p9000’s rom … Which is ported … Or you can tweak with your wifi settings

@GaVy
Sorry, how can i tweak wifi settings? Flyme os wifi settings are very limited. Is there a specific app?

I will not suggest any app as no app will boost wifi signal … But u can change some values to get better signal it is bit risky . You must have root permissions . And you can google it

@GaVy
But if no one else had this problem while having the same firmware, how can it be a software matter?

Does anyone else hear crackling noise through headphones when sound starts and a few seconds after it ends?

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.