Stuck at boot logo after attempt to switch from version A to G

Received my phone yesterday and soon updated Flyme from 4.5.x.xA to 5.1.2.0A without any problem.

Issue
I proceeded with following method two using terminal from this guide to switch to version G.

The installation completed successfully, but after restart I am stuck at the start screen with Meizu logo.

Steps taken

  • I have restarted the phone in recovery mode (vol up + power) and transferred different versions of the update.zip files and then tried to update with them. Every time the result is that I get returned to the system upgrade screen with a warning and the text “Firmware corrupt”.
    The different update.zip files I have tried with includes 4.5.x.x.A, 5.1.2.0A and 5.1.2.0G (unmodified). All of them give me the “Firmware corrupt” text. Worth noting is that the file is not on the phones recovery partition after the failed upgrade attempts (even when I do not select clear data)
  • Many tries with clearing the data
  • I have tried to put the update.zip files to the phone from different computers
  • I have formatted the recovery partition on the phone to FAT32 (since I read that this helped in one case)
  • I have tried to connect to the phone over ADB but am not successful, the device cannot be found. If I go into Fastboot (vol down + power) I get Fastboot mode (locked, rooted)

Any help is appreciated. It seems like a really good phone the minutes I used it before bricking it :)

@Xeon64

Holy macaroni. It seems posting this was the solution. Together with me downloading 5.1.2.0A on another computer than earlier and transferring it to the phone.

The A version is now on the phone and it is working again.

More precaution will be taken before next switch to global version will take place, which probably will happen within a day.

Cheers and have a nice weekend Meizufans!

@Xeon64 Obviously you have no problem with your command of the English language so my question to you is this: Why do you feel the need to flash the global version instead of the nearly identical but more frequently updated A version?

From my experience, the only differences between the two firmwares are more languages on the Global and a few easily uninstalled China specific apps on the A version.
I don’t get the fascination with the Global firmware.

@ShadowOfDeth
I am not only fascinated by the Global version but lie sleepless over not having it on my phone… No, jokes aside, it was just the path I took to get the following:

  • Interface without any Chinese left in the core
  • Google Play Services
  • Possibility to switch to other languages (DUH!!!)

Yes, I am aware that the interface can be fixed with some tricks which includes rooting the device (which mine obviously is) and replacing some files.

Yes, I know that Google Play can be fixed in other ways.

As it turns out the G version does not support Swedish which would have been useful. It does support Polish which likely will be useful for me.

I hope I answered your questions but if not and you would like more details about my living situation, family and future plans for the phone in near time please get back and I will be happy to provide more details.

Cheers,
X

@Xeon64 lol. That passive aggressive snark doe haha. Easy tiger, I was just curious. Relax.

Contributor

@Xeon64 Please tell us more about your living situation, your childhood, if you have a trauma from it and so on.

It’s not related to this topic or Meizu, yet probably entertaining.

I hardly doubt that languages will be added to the Global firmware… and this is because the languages support right now aren’t proper translated.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.