Meizu MX4 Semi-Bricked

I after, trying to downgrade from flyme5 beta to flyme4 (I), my phone won’t boot anymore. Just show only “MEIZU”, but enter fastboot mode and recovery. I tried all official firmware, but when i try to flash it in recovery (official), they say “FIRMWARE CORRUPT”. What i can do?

Meizu Pro 5

@xator Double check your phone version … Chinese one need A version …

@Kikounet95 said:

@xator Double check your phone version … Chinese one need A version …

I know, i have used the guide for flash the firmware through adb. After that, the phone wont boot, tried too to flash inside the recovery a (A) firmware. tried a lot of version. Tried too the unbrick guide on this forum, but i need “AUTHENTICATION FILE” … There is something i can do to force the upgrade, throught update.zip inside the stock recovery? Or something to do with fastboot?

Meizu Pro 5

@xator As your phone can boot in recovery i would flash the “correct” update.zip only (directly in recovery, not though adb or whatever converting method), this is less risky and more efficient
Correct means the A version for Chinese phone, and I version for international … So check you device serial/id

@Kikounet95 I tried to flash in recovery the “A” version, because mine is “A” version and they say “FIRMWARE CORRUPT”

I tried these version:

4.0.4 ©
4.0.4 (A)
4.0.4 (I)
5.6.1.12 (A)
5.6.1.26 (A)
4.5.7 (A)
4.5.7 (I)

Why they say “Firmware Corrupt”, even if firmware is ok? I transfer it in recovery partition that appear when i put the phone in recovery while is plugged USB

Meizu Pro 5

@xator firmware corrupted is the generic message …
So stick with A firmware anyway, I won’t work.

  • Did the file update.zip is ok (on your computer) ?
    -Check you named it update.zip before recover

@Kikounet95 Yes it is named ok, “update.zip”. I tried to boot up the phone, but just hang up to “MEIZU” logo. If i try to flash an “A” firmware, just say firmware corrupt, even if i try clear data… I really going mad

PS: Just checked the MD5, and when i copy inside the recovery partition of mx4, they change the MD5 of the update.zip, it’s normal?

last edited by xator

I see while transfer the update.zip, the transfer speed go down to 0kb/s for 10 sec, and after going up again, maybe this will corrupt the file zip, this is the reason for different MD5, so how i can transfer it without loosing data?

Admin

@xator please do not double post.

Did you tried a different cable or USB port?
Often that helps.

@Rey Yes tried it . Always copy bad zip file

Tried with a windows 7 PC, 4.0.4.1 (A), transfer fine, md5 ok, but always “Firmware Corrupt”

Admin

@xator where you bought your device from?
Was it a local store/EU based seller?

If yes, you are screwed as it is a TCCM device and therefore locked.

Fixed, after try to update, with 4.5.7 (A), the phone boot. Sorry for double post, i was really mad

Admin

@xator no problem.

Glad you figured it out!
However, I still wonder why it didn’t worked in first place. Maybe it was related to a lock introduced in Flyme 4.5.5.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.