[How to] Flyme 5 Push Notifications delay - fix

Hi,
After 2 days and with help from meizufans users I know how to fix problem with notifications delay.

All You need is go to “Security” app and:

  1. Accelerator -> Settings - > Memory acceleration… - > Add to white list and then check google play services and apps You want to not to be cleaned eg. Whatsapp
  2. Permissions - >Auto run management - > and check google play services and some apps You want to auto start when closed like Gmail etc.
  3. In Permissions select all in Notifications management
  4. Power - > App management - >and select google play services and apps You don’t want to be auto closed after 3 minutes of idle.

That’s all :) I also installed PNF Root from G play, but probably You don’t need it

last edited by szmerd
Contributor

Thanks for sharing it.

Does this also fix the deep sleep notification bug?

i have tired but didnt work for me

@chittapanu HAve You tried all of tips ? It should definitely works

The way to fix this is just to keep alive GoolePlayServices. The push notifications for Whatsapp and other programs depende of this service.

last edited by SuRender Infografía

Hi,

This tips worked for the update which was 2 montch ago.

But now after I have updated my phone yesterday to version 5.6.3.15 beta I have again problem with the notifications…
WTF Meizu???

Does anybody know how to fix it again using other ideas than this one?

@Mikasa read someone cleared data of security center app.

I am having the same problem in ALL of “A” betas since 08 MARCH 2015 (08/15/22 versions).

Notifications simply stop working.

  • Cleared data on both Security App and Whatsapp
  • Disabled and Re-enabled in Security Center Auto Startup, Power Management, and Cleanup Whitelist
  • Reset heartbeat using PNF Root

no way, notifications do not work after some 5-10 minutes of the phone being in idle.

Returned back to beta 22/FEB (I like that one most) and notifications start working smoothly again.

As “Mikasa” said, WTF Meizu!!!

last edited by rubiohiguey
Meizu MX4 Pro

@rubiohiguey i also upgraded from an old stable Version to the latest and even my f**** Widgets have stopped working !!! my clock & weather Widget still Displays the time from yesterday !!!

Hi all,

My MX5 is on Flyme 5.6.6.21 beta. I tried basically everything that is mentioned in this thread and other threads. My Whatsapp notifications just failed eventually.

So, my desperate move is to use a tool to periodically launch Whatsapp! I am using the Automate app by LlamaLab. The task that I created is having the following logic:

  1. Flow beginning.
  2. App start: specify “com.whatsapp” package.
  3. Delay: 2 mins. (Specify what you prefer here.)
  4. Goto App start again (item 2 above).

This task would periodically launch Whatsapp after a given delay. Of course, I have to live with the periodic interruption where Whatsapp suddenly comes into the foreground; I have to swipe back to continue with whatever I am doing before that.

Since I am relying on the Automate app, I need to configure in the Security app so that it is to be kept stand-by when idle, auto-launched and whitelisted from memory scan.

Hope this might help some desperate folks. It is not a solution, just a workaround.

Edit: Since firmware 5.7.1.0A, it seemed that turning off Security - Power - Settings - Disable interactive activation of apps was sufficient. No need for the Automate task.

last edited by karl.heng

@karl.heng said in [How to] Flyme 5 Push Notifications delay - fix:

Edit: Since firmware 5.7.1.0A, it seemed that turning off Security - Power - Settings - Disable interactive activation of apps was sufficient. No need for the Automate task.

I presume is typo, should be 5.1.7.0A right??
And the “Disable interactive activation of apps” should be ON or OFF??
Thanks

last edited by ronald_loulan

@ronald_loulan said in [How to] Flyme 5 Push Notifications delay - fix:

@karl.heng said in [How to] Flyme 5 Push Notifications delay - fix:

Edit: Since firmware 5.7.1.0A, it seemed that turning off Security - Power - Settings - Disable interactive activation of apps was sufficient. No need for the Automate task.

I presume is typo, should be 5.1.7.0A right??
And the “Disable interactive activation of apps” should be ON or OFF??
Thanks

Yes, it’s 5.1.7.0A. That is a big typo. Thanks.

“Disable interactive activation of apps” should NOT be SELECTED. I am not too sure if this is considered ON or OFF.

last edited by karl.heng

I’ve remove the Security app but still get delay sometimes…
Is far more better than keeping the useless security centre that cant do its job…
Will wait for the next OS release…
And WTF MEIZU!!!???

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.