PRO 5 problem in Google installer and network signal after upgrade firmware
Meizu Pro 5

My PRO 5 is China version , after upgrade firmware to OS 5.1.2.0A
and than I install Google installer but couldn’t open it and mention there :
Repair Tip
Found this module has been damaged, click “A Key To Install” to repair it.

I have try many time to repair but no succssthe result.

And one more thing:
My network signal is not function even shown there 4G signal present.

Anybody could like to help me, please?

last edited by sutiknya
Meizu Pro 5

I updated to the same version a few days ago. At first it was ok. They did some really stupid changes. I use hotspot alot. Now it’s not on scortcut anymore,when you drag down . Also there are some browsing problems, The browser that comes with the phone is not good. Colors/res is bad,i tried with other browsers to compare with and i can clearly see the different,also it loads pages slow. I tried chrome and firefox to compare with. And they are faster. But now i have a new problem , its the same in all browsers. I can not load some pages and pictures dont loads at all.

I downloaded the update from flyme.cn directly from my phone with 4g/lte mobiledata.
When you finish download open file and you get a message to update phone.
I did not lose any data when i upgraded. You get to chose if you want to clear all data when you update.

About LTE i had some of the same thing. I was moving from from a place where there are H++ to LTE/4g/4G+ and then back again. My phone showed edge speed,i figured it was wierd so i tried with my other phone to check if the problem was the same,it was not . So on my meizu i changed from 4g to 3g . On 3g i got the h++ speed back ,then i putted it on 4g again and i had the same speed i wanted back. You could try something like that.

Did not your phone come with Google play? mine did.

What

last edited by Boller

Had same problem. Never happened the last time I had the latest stable. But try this:

https://meizufans.eu/forum/topic/4173/can-t-install-google-services-from-google-installer

Worked for me ;)

One other thing, has anyone noticed an issue with the keyboard blocking half the screen and not being able to scroll the page to see what you’re typing?

After many workarounds I found the solution by installing version 1.4.4. taken here:
https://downloads.meizufans.eu/apps/google_installer/
It’s an old version but all google apps will be updated once you enter the Play Store.

i was also having same problem and tried many things. in the end when i installed google play 6.5 and it updated automatically now google play is working fine

Meizu Pro 5

There is another method to reinstall Google apps, simply restoring the backups done with Titanium backup. Just keep titanium apk in external SDCard so you don’t need playstore as a prerequisite.

This is so easy, just log in google play with different account it will work then sign out and log in with your original account, enjoy it :kissing:

Admin

@mancian there is already a fix. The correct way to do it:

  1. Remove Google account from the Settings.
  2. Clear Play Store and Play Services data.
  3. Reboot.
  4. Log in again and enjoy.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.