How to configure the clock?

Well, I am having a lot of troubles with my Meizu M2 Mini. Apart from configuring the clock, I also have a battery issue (drops from 45 to 7 and then to 0 afer a few secs). But let’s focus on the clock thing first.
I ad a new city (Berlin/Germany). But how can I configurate it that it will be shown in the upper left site of my phone? Or how can I delete the Bejing thing? The only thing I can do is change the order but the Bejing time still remains.
Installed firmware: Flyme OS 4.5.4.2 A

Go to tge setting app -> language and time and then set your time zone to automatic and if it still doesnt work configure it manually

@RoeiG said:

Go to tge setting app -> language and time and then set your time zone to automatic and if it still doesnt work configure it manually

Thank you, I finally found it in the settings.

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.