messaging not working - sim card not selected

I just got a new meizu M2 and I am very happy with it. Now, using google messenger, I cannot send out text messages. A message says “you have not selected your preferred sim card yet”. I only have on sim card and it’s in slot 1. Calling and everything else works.

Where do you select your preferred sim card for messaging? or any other solution to this problem?

By now Flyme doesnt have the option to select preffered sim card for messages. Its own messenger gives you option to choose the sim card while sending, but stock android, including Google Messenger doesnt support that. You can install the Elephone port stock-like rom on your device, works flawlessly with me.

last edited by Ertugrul Kahraman

@merira Have you freeze/uninstall the stock SMS app?
Please little bit search on this forum and read another topic about the similar issues withn3rd pty SMS apps

Looks like your connection to Meizufans was lost, please wait while we try to reconnect.